0594acf27e
Changes: *) Make pth_poll(3) more compliant to POSIX.1-2001/SUSv3 poll(2). *) Make pth_select(3) more compliant to POSIX.1-2001/SUSv3 select(2). *) Replaced pth_event_occurred() with pth_event_status(). *) Add Autoconf option --with-fdsetsize=NUM for enlarging FD_SETSIZE. *) Added thread attribute PTH_ATTR_DISPATCHES. *) Added sub-API pth_uctx_* for user-space context switching. *) Add a Pth variant of the new POSIX pselect(2) function. *) Internally cleaned up the error handling macros. *) Added POSIX-compliant sanity checks for bad fds. *) Added pth_nanosleep() function. *) Allow a NULL name for pth_msgport_create() *) Completely rewrote the "hard syscall mapping". *) Added support to pth_poll(3) for POLLD{RD,WR}{NORM,BAND}. *) Fixed a long-standing termination bug in pth_exit(3). *) Upgraded to Autoconf 2.57, Shtool 1.6.2 and Libtool 1.4.3. *) Add optional support for OSSP ex based exception handling.
37 lines
1.3 KiB
Text
37 lines
1.3 KiB
Text
$NetBSD: patch-ae,v 1.3 2003/05/02 11:49:48 wiz Exp $
|
|
|
|
--- configure.ac.orig Wed Jan 1 15:45:06 2003
|
|
+++ configure.ac
|
|
@@ -190,7 +190,7 @@ dnl # check for various other functions
|
|
AC_CHECK_FUNCS(usleep strerror)
|
|
|
|
dnl # check for various other headers which we might need
|
|
-AC_HAVE_HEADERS(sys/resource.h net/errno.h paths.h)
|
|
+AC_HAVE_HEADERS(net/errno.h paths.h)
|
|
|
|
dnl # at least the test programs need some socket stuff
|
|
AC_CHECK_LIB(nsl, gethostname)
|
|
@@ -208,6 +208,15 @@ if test ".$ac_cv_header_sys_select_h" !=
|
|
fi
|
|
AC_SUBST(EXTRA_INCLUDE_SYS_SELECT_H)
|
|
|
|
+dnl # check whether we've to use a non-standard #include <sys/resource.h> to get
|
|
+dnl # the definition for struct rusage on platforms that support it.
|
|
+AC_HAVE_HEADERS(sys/resource.h)
|
|
+EXTRA_INCLUDE_SYS_RESOURCE_H="#include <sys/resource.h>"
|
|
+if test ".$ac_cv_header_sys_resource_h" != .yes; then
|
|
+ EXTRA_INCLUDE_SYS_RESOURCE_H="/* $EXTRA_INCLUDE_SYS_RESOURCE_H */"
|
|
+fi
|
|
+AC_SUBST(EXTRA_INCLUDE_SYS_RESOURCE_H)
|
|
+
|
|
dnl # check whether we've to define sig_atomic_t
|
|
AC_CHECK_TYPEDEF(sig_atomic_t, signal.h)
|
|
FALLBACK_SIG_ATOMIC_T="typedef int sig_atomic_t;"
|
|
@@ -618,6 +627,7 @@ fi
|
|
AC_SUBST(PTHREAD_O)
|
|
AC_SUBST(LIBPTHREAD_A)
|
|
AC_SUBST(LIBPTHREAD_LA)
|
|
+AC_SUBST(LIBTOOL)
|
|
AC_SUBST(PTHREAD_CONFIG_1)
|
|
AC_SUBST(PTHREAD_3)
|
|
AC_SUBST(INSTALL_PTHREAD)
|