pkgsrc/databases/postgresql13/patches/patch-src_Makefile.global.in
adam 8ecbf81f41 postgresql13: added version 13.0
PostgreSQL 13 contains many new features and enhancements, including:
* Space savings and performance gains from de-duplication of B-tree index entries
* Improved performance for queries that use aggregates or partitioned tables
* Better query planning when using extended statistics
* Parallelized vacuuming of indexes
* Incremental sorting
2020-10-18 09:24:02 +00:00

18 lines
447 B
Text

$NetBSD: patch-src_Makefile.global.in,v 1.1 2020/10/18 09:24:02 adam Exp $
Fix building on Cygwin.
--- src/Makefile.global.in.orig 2020-09-21 20:47:36.000000000 +0000
+++ src/Makefile.global.in
@@ -728,6 +728,11 @@ ifeq ($(PORTNAME),win32)
LIBS += -lws2_32
endif
+# missing for link on cygwin ?
+ifeq ($(PORTNAME),cygwin)
+LIBS += $(LDAP_LIBS_BE)
+endif
+
# Not really standard libc functions, used by the backend.
TAS = @TAS@