8ecbf81f41
PostgreSQL 13 contains many new features and enhancements, including: * Space savings and performance gains from de-duplication of B-tree index entries * Improved performance for queries that use aggregates or partitioned tables * Better query planning when using extended statistics * Parallelized vacuuming of indexes * Incremental sorting
64 lines
1.8 KiB
Text
64 lines
1.8 KiB
Text
$NetBSD: patch-src_Makefile.shlib,v 1.1 2020/10/18 09:24:02 adam Exp $
|
|
|
|
Use correct linker flags.
|
|
|
|
--- src/Makefile.shlib.orig 2020-09-21 20:47:36.000000000 +0000
|
|
+++ src/Makefile.shlib
|
|
@@ -151,9 +151,6 @@ ifeq ($(PORTNAME), openbsd)
|
|
endif
|
|
|
|
ifeq ($(PORTNAME), freebsd)
|
|
- ifdef SO_MAJOR_VERSION
|
|
- shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
|
- endif
|
|
LINK.shared = $(COMPILER) -shared
|
|
ifdef soname
|
|
LINK.shared += -Wl,-x,-soname,$(soname)
|
|
@@ -177,6 +174,17 @@ ifeq ($(PORTNAME), netbsd)
|
|
endif
|
|
endif
|
|
|
|
+ifeq ($(PORTNAME), dragonfly)
|
|
+ ifdef ELF_SYSTEM
|
|
+ LINK.shared = $(COMPILER) -shared
|
|
+ ifdef soname
|
|
+ LINK.shared += -Wl,-x,-soname,$(soname)
|
|
+ endif
|
|
+ else
|
|
+ LINK.shared = $(LD) -x -Bshareable -Bforcearchive
|
|
+ endif
|
|
+endif
|
|
+
|
|
ifeq ($(PORTNAME), hpux)
|
|
ifdef SO_MAJOR_VERSION
|
|
shlib = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
|
|
@@ -232,7 +240,7 @@ ifeq ($(PORTNAME), solaris)
|
|
ifeq ($(with_gnu_ld), yes)
|
|
LINK.shared += -Wl,-soname,$(soname)
|
|
else
|
|
- LINK.shared += -h $(soname)
|
|
+ LINK.shared += -Wl,-h,$(soname)
|
|
endif
|
|
endif
|
|
endif
|
|
@@ -429,8 +437,10 @@ ifdef soname
|
|
# we don't install $(shlib) on AIX
|
|
# (see http://archives.postgresql.org/message-id/52EF20B2E3209443BC37736D00C3C1380A6E79FE@EXADV1.host.magwien.gv.at)
|
|
ifneq ($(PORTNAME), aix)
|
|
+ifeq ($(PORTNAME), cygwin)
|
|
+ $(INSTALL_SHLIB) $< '$(DESTDIR)$(bindir)/$(shlib)'
|
|
+else
|
|
$(INSTALL_SHLIB) $< '$(DESTDIR)$(libdir)/$(shlib)'
|
|
-ifneq ($(PORTNAME), cygwin)
|
|
ifneq ($(PORTNAME), win32)
|
|
ifneq ($(shlib), $(shlib_major))
|
|
cd '$(DESTDIR)$(libdir)' && \
|
|
@@ -443,7 +453,7 @@ ifneq ($(shlib), $(shlib_bare))
|
|
$(LN_S) $(shlib) $(shlib_bare)
|
|
endif
|
|
endif # not win32
|
|
-endif # not cygwin
|
|
+endif # cygwin
|
|
endif # not aix
|
|
ifneq (,$(findstring $(PORTNAME),win32 cygwin))
|
|
$(INSTALL_SHLIB) $< '$(DESTDIR)$(bindir)/$(shlib)'
|