debd7c106d
v1.8.0 "Northern Shoveler Duck" This release focused on encoding performance for realtime and VOD use cases. - Upgrading: This adds and improves several vp9 controls. Most are related to SVC: VP9E_SET_SVC_FRAME_DROP_LAYER: - Frame dropping in SVC. VP9E_SET_SVC_INTER_LAYER_PRED: - Inter-layer prediction in SVC. VP9E_SET_SVC_GF_TEMPORAL_REF: - Enable long term temporal reference in SVC. VP9E_SET_SVC_REF_FRAME_CONFIG/VP9E_GET_SVC_REF_FRAME_CONFIG: - Extend and improve this control for better flexibility in setting SVC pattern dynamically. VP9E_SET_POSTENCODE_DROP: - Allow for post-encode frame dropping (applies to non-SVC too). VP9E_SET_SVC_SPATIAL_LAYER_SYNC: - Enable spatial layer sync frames. VP9E_SET_SVC_LAYER_ID: - Extend api to specify temporal id for each spatial layers. VP9E_SET_ROI_MAP: - Extend Region of Interest functionality to VP9. - Enhancements: 2 pass vp9 encoding has improved substantially. When using --auto-alt-ref=6, we see approximately 8% for VBR and 10% for CQ. When using --auto-alt-ref=1, the gains are approximately 4% for VBR and 5% for CQ. For real-time encoding, speed 7 has improved by ~5-10%. Encodes targeted at screen sharing have improved when the content changes significantly (slide sharing) or scrolls. There is a new speed 9 setting for mobile devices which is about 10-20% faster than speed 8. - Bug fixes: VP9 denoiser issue. VP9 partition issue for 1080p. VP9 rate control improvments. Postprocessing Multi Frame Quality Enhancement (MFQE) issue. VP8 multithread decoder issues. A variety of fuzzing issues.
130 lines
5.1 KiB
Text
130 lines
5.1 KiB
Text
$NetBSD: patch-build_make_Makefile,v 1.1 2019/02/12 20:47:14 adam Exp $
|
|
|
|
--- build/make/Makefile.orig 2017-01-12 20:27:27.000000000 +0000
|
|
+++ build/make/Makefile
|
|
@@ -147,7 +147,7 @@ $(BUILD_PFX)%.c.d: %.c
|
|
$(BUILD_PFX)%.c.o: %.c
|
|
$(if $(quiet),@echo " [CC] $@")
|
|
$(qexec)$(if $(CONFIG_DEPENDENCY_TRACKING),,mkdir -p $(dir $@))
|
|
- $(qexec)$(CC) $(INTERNAL_CFLAGS) $(CFLAGS) -c -o $@ $<
|
|
+ $(qexec)${LIBTOOL} --mode=compile $(CC) $(INTERNAL_CFLAGS) $(CFLAGS) -c -o $@ $<
|
|
|
|
$(BUILD_PFX)%.cc.d: %.cc
|
|
$(if $(quiet),@echo " [DEP] $@")
|
|
@@ -157,7 +157,7 @@ $(BUILD_PFX)%.cc.d: %.cc
|
|
$(BUILD_PFX)%.cc.o: %.cc
|
|
$(if $(quiet),@echo " [CXX] $@")
|
|
$(qexec)$(if $(CONFIG_DEPENDENCY_TRACKING),,mkdir -p $(dir $@))
|
|
- $(qexec)$(CXX) $(INTERNAL_CFLAGS) $(CXXFLAGS) -c -o $@ $<
|
|
+ $(qexec)${LIBTOOL} --mode=compile $(CXX) $(INTERNAL_CFLAGS) $(CXXFLAGS) -c -o $@ $<
|
|
|
|
$(BUILD_PFX)%.cpp.d: %.cpp
|
|
$(if $(quiet),@echo " [DEP] $@")
|
|
@@ -167,7 +167,7 @@ $(BUILD_PFX)%.cpp.d: %.cpp
|
|
$(BUILD_PFX)%.cpp.o: %.cpp
|
|
$(if $(quiet),@echo " [CXX] $@")
|
|
$(qexec)$(if $(CONFIG_DEPENDENCY_TRACKING),,mkdir -p $(dir $@))
|
|
- $(qexec)$(CXX) $(INTERNAL_CFLAGS) $(CXXFLAGS) -c -o $@ $<
|
|
+ $(qexec)${LIBTOOL} --mode=compile $(CXX) $(INTERNAL_CFLAGS) $(CXXFLAGS) -c -o $@ $<
|
|
|
|
$(BUILD_PFX)%.asm.d: %.asm
|
|
$(if $(quiet),@echo " [DEP] $@")
|
|
@@ -178,7 +178,8 @@ $(BUILD_PFX)%.asm.d: %.asm
|
|
$(BUILD_PFX)%.asm.o: %.asm
|
|
$(if $(quiet),@echo " [AS] $@")
|
|
$(qexec)$(if $(CONFIG_DEPENDENCY_TRACKING),,mkdir -p $(dir $@))
|
|
- $(qexec)$(AS) $(ASFLAGS) -o $@ $<
|
|
+ $(qexec)${LIBTOOL} --mode=compile --tag=CC sh strip_fPIC.sh \
|
|
+ $(AS) $(ASFLAGS) -o $@ $<
|
|
|
|
$(BUILD_PFX)%.S.d: %.S
|
|
$(if $(quiet),@echo " [DEP] $@")
|
|
@@ -189,7 +190,8 @@ $(BUILD_PFX)%.S.d: %.S
|
|
$(BUILD_PFX)%.S.o: %.S
|
|
$(if $(quiet),@echo " [AS] $@")
|
|
$(qexec)$(if $(CONFIG_DEPENDENCY_TRACKING),,mkdir -p $(dir $@))
|
|
- $(qexec)$(AS) $(ASFLAGS) -o $@ $<
|
|
+ $(qexec)${LIBTOOL} --mode=compile --tag=CC sh strip_fPIC.sh \
|
|
+ $(AS) $(ASFLAGS) -o $@ $<
|
|
|
|
.PRECIOUS: %.c.S
|
|
%.c.S: CFLAGS += -DINLINE_ASM
|
|
@@ -254,13 +256,15 @@ define linker_template
|
|
$(1): $(filter-out -%,$(2))
|
|
$(1):
|
|
$(if $(quiet),@echo " [LD] $$@")
|
|
- $(qexec)$$(LD) $$(strip $$(INTERNAL_LDFLAGS) $$(LDFLAGS) -o $$@ $(2) $(3) $$(extralibs))
|
|
+ $(qexec)${LIBTOOL} --mode=link $(CXX) $(LDFLAGS) -o $$@ \
|
|
+ $$(filter-out -lvpx,$(2)) libvpx.la $$(extralibs)
|
|
endef
|
|
define linkerxx_template
|
|
$(1): $(filter-out -%,$(2))
|
|
$(1):
|
|
$(if $(quiet),@echo " [LD] $$@")
|
|
- $(qexec)$$(CXX) $$(strip $$(INTERNAL_LDFLAGS) $$(LDFLAGS) -o $$@ $(2) $(3) $$(extralibs))
|
|
+ $(qexec)${LIBTOOL} --mode=link ${CXX} $(LDFLAGS) -o $$@ \
|
|
+ $$(filter-out -lvpx,$(2)) libvpx.la $$(extralibs)
|
|
endef
|
|
# make-3.80 has a bug with expanding large input strings to the eval function,
|
|
# which was triggered in some cases by the following component of
|
|
@@ -273,8 +277,12 @@ endef
|
|
define install_map_template
|
|
$(DIST_DIR)/$(1): $(2)
|
|
$(if $(quiet),@echo " [INSTALL] $$@")
|
|
- $(qexec)mkdir -p $$(dir $$@)
|
|
- $(qexec)cp -p $$< $$@
|
|
+ $(qexec)${BSD_INSTALL_DATA} -d -m 755 $$(dir $$@)
|
|
+ $$(if $$(filter %.a,$$<), \
|
|
+ ${LIBTOOL} --mode=install ${BSD_INSTALL_LIB} -c $$(patsubst %.a,%.la,$$<) $$(dir $$@), \
|
|
+ $$(if $$(filter %.h %.pc,$$<), \
|
|
+ ${BSD_INSTALL_DATA} -c -m 644 $$< $$(dir $$@), \
|
|
+ ${LIBTOOL} --mode=install ${BSD_INSTALL_LIB} -c -s $$< $$(dir $$@)))
|
|
endef
|
|
|
|
define archive_template
|
|
@@ -283,7 +291,9 @@ define archive_template
|
|
# for creating them.
|
|
$(1):
|
|
$(if $(quiet),@echo " [AR] $$@")
|
|
- $(qexec)$$(AR) $$(ARFLAGS) $$@ $$^
|
|
+ $(qexec)${LIBTOOL} --mode=link $(CC) $(LDFLAGS) -Wl,-Bsymbolic -o $$(patsubst %.a,%.la,$$@) \
|
|
+ $$(patsubst %.o,%.lo,$$?) -rpath $(PREFIX)/lib $$(extralibs) \
|
|
+ -version-info $(VERSION_MAJOR):$(VERSION_MINOR):$(VERSION_PATCH)
|
|
endef
|
|
|
|
define so_template
|
|
@@ -377,9 +387,9 @@ clean::
|
|
rm -f .bins .install-bins $(BINS)
|
|
|
|
LIBS=$(call enabled,LIBS)
|
|
-.libs: $(LIBS)
|
|
+dot.libs: $(LIBS)
|
|
@touch $@
|
|
-$(foreach lib,$(filter %_g.a,$(LIBS)),$(eval $(call archive_template,$(lib))))
|
|
+$(foreach lib,$(filter %.a,$(LIBS)),$(eval $(call archive_template,$(lib))))
|
|
$(foreach lib,$(filter %so.$(SO_VERSION_MAJOR).$(SO_VERSION_MINOR).$(SO_VERSION_PATCH),$(LIBS)),$(eval $(call so_template,$(lib))))
|
|
$(foreach lib,$(filter %$(SO_VERSION_MAJOR).dylib,$(LIBS)),$(eval $(call dl_template,$(lib))))
|
|
$(foreach lib,$(filter %$(SO_VERSION_MAJOR).dll,$(LIBS)),$(eval $(call dll_template,$(lib))))
|
|
@@ -388,11 +398,11 @@ INSTALL-LIBS=$(call cond_enabled,CONFIG_
|
|
ifeq ($(MAKECMDGOALS),dist)
|
|
INSTALL-LIBS+=$(call cond_enabled,CONFIG_INSTALL_LIBS,DIST-LIBS)
|
|
endif
|
|
-.install-libs: .libs $(addprefix $(DIST_DIR)/,$(INSTALL-LIBS))
|
|
+.install-libs: dot.libs $(addprefix $(DIST_DIR)/,$(INSTALL-LIBS))
|
|
@touch $@
|
|
|
|
clean::
|
|
- rm -f .libs .install-libs $(LIBS)
|
|
+ rm -f dot.libs .install-libs $(LIBS)
|
|
|
|
ifeq ($(CONFIG_EXTERNAL_BUILD),yes)
|
|
PROJECTS=$(call enabled,PROJECTS)
|
|
@@ -442,7 +452,7 @@ ifeq ($(CONFIG_EXTERNAL_BUILD),yes)
|
|
BUILD_TARGETS += .projects
|
|
INSTALL_TARGETS += .install-projects
|
|
endif
|
|
-BUILD_TARGETS += .docs .libs .bins
|
|
+BUILD_TARGETS += .docs dot.libs .bins
|
|
INSTALL_TARGETS += .install-docs .install-srcs .install-libs .install-bins
|
|
all: $(BUILD_TARGETS)
|
|
install:: $(INSTALL_TARGETS)
|