pkgsrc/devel/monodevelop/patches/patch-ae
kefren 5d97c9727c Use ${MAKE_PROGRAM} instead of hardcoding gmake. The latter will cause
problems on linux systems. Bump PKGREVISION. Noticed by Tobias Nygren
2010-04-17 17:11:04 +00:00

20 lines
1.1 KiB
Text

$NetBSD: patch-ae,v 1.2 2010/04/17 17:11:05 kefren Exp $
--- src/addins/MonoDevelop.Autotools/templates/Makefile.noauto.project.template.orig 2010-04-16 13:17:14.000000000 +0300
+++ src/addins/MonoDevelop.Autotools/templates/Makefile.noauto.project.template 2010-04-16 13:17:28.000000000 +0300
@@ -32,12 +32,12 @@
%%CUSTOM_COMMAND_TARGETS%%
$(ASSEMBLY_MDB): $(ASSEMBLY)
$(ASSEMBLY): $(build_sources) $(build_resources) $(build_datafiles) $(DLL_REFERENCES) $(PROJECT_REFERENCES) $(build_xamlg_list) $(build_satellite_assembly_list)
- make pre-all-local-hook prefix=$(prefix)
+ MAKEPROGRAM pre-all-local-hook prefix=$(prefix)
mkdir -p $(shell dirname $(ASSEMBLY))
- make $(CONFIG)_BeforeBuild
+ MAKEPROGRAM $(CONFIG)_BeforeBuild
$(ASSEMBLY_COMPILER_COMMAND) $(ASSEMBLY_COMPILER_FLAGS) -out:$(ASSEMBLY) -target:$(COMPILE_TARGET) $(build_sources_embed) $(build_resources_embed) $(build_references_ref)
- make $(CONFIG)_AfterBuild
- make post-all-local-hook prefix=$(prefix)
+ MAKEPROGRAM $(CONFIG)_AfterBuild
+ MAKEPROGRAM post-all-local-hook prefix=$(prefix)
%%INSTALL_TARGET%%
%%UNINSTALL_TARGET%%