buildlink2.mk files back into the main trunk. This provides sufficient buildlink2 infrastructure to start merging other packages from the buildlink2 branch that have already been converted to use the buildlink2 framework.
52 lines
1.7 KiB
Text
52 lines
1.7 KiB
Text
$NetBSD: patch-aa,v 1.17 2002/08/25 18:40:32 jlam Exp $
|
|
|
|
--- configure.orig Tue Jan 22 14:35:12 2002
|
|
+++ configure
|
|
@@ -3271,12 +3271,9 @@
|
|
|
|
|
|
|
|
-GLIB_CFLAGS=`echo $GTK_CFLAGS | sed 's/^.*\(-I[^ ]*glib[^ ]* *-I[^ ]*\).*$/\1/'`
|
|
-GLIB_LDFLAGS=`echo $GTK_LIBS | sed -e 's/^.*-lgdk[^ ]* *\(-L[^ ]*\).*$/\1/' -e 's/^.* -lgdk[^ ]* .*$//'`
|
|
-if test -z "$GLIB_LDFLAGS" ; then
|
|
- GLIB_LDFLAGS=`echo $GTK_LIBS | sed -e 's/\(-L[^ ]*\) .*$/\1/' -e 's/^.*\(-L[^ ]*\)$/\1/'`
|
|
-fi
|
|
-GLIB_LIBS="$GLIB_LDFLAGS `echo $GTK_LIBS | sed 's/^.*\(-lglib[^ ]*\).*$/\1/'`"
|
|
+GLIB_CFLAGS="`glib-config --cflags`"
|
|
+GLIB_LIBS="`glib-config --libs`"
|
|
+GLIB_LDFLAGS="$GLIB_LIBS"
|
|
|
|
|
|
|
|
@@ -5127,6 +5124,11 @@
|
|
rm -f po/POTFILES
|
|
sed -e "/^#/d" -e "/^\$/d" -e "s,.*, $posrcprefix& \\\\," -e "\$s/\(.*\) \\\\/\1/" \
|
|
< $srcdir/po/POTFILES.in > po/POTFILES
|
|
+
|
|
+# NetBSD: set DATADIRNAME to "share"
|
|
+DATADIRNAME="${PKGLOCALEDIR}"
|
|
+INTLDEPS=
|
|
+INTLLIBS="-lintl"
|
|
|
|
# AM_GNOME_GETTEXT above substs $DATADIRNAME
|
|
# this is the directory where the *.{mo,gmo} files are installed
|
|
@@ -9942,7 +9944,7 @@
|
|
GTKXMHTML_LIBS="-lgtkxmhtml $LIBGTKXMHTML_LIBS"
|
|
ZVT_LIBS="-lzvt $UTIL_LIBS $GTK_LIBS"
|
|
|
|
-GNOME_LIBDIR='-L${libdir}'
|
|
+GNOME_LIBDIR='-L${libdir} -Wl,-R${libdir}'
|
|
GNOME_INCLUDEDIR='-I${includedir}/gnome-1.0 -DNEED_GNOMESUPPORT_H -I${pkglibdir}/include'
|
|
GNOME_IDLDIR='-I${datadir}/idl'
|
|
|
|
@@ -10046,8 +10048,8 @@
|
|
fi
|
|
if test x$gnome_cv_orbit_found = xyes; then
|
|
|
|
- ORBIT_CFLAGS=`orbit-config --cflags client server`
|
|
- ORBIT_LIBS=`orbit-config --use-service=name --libs client server`
|
|
+ ORBIT_CFLAGS=`$ORBIT_CONFIG --cflags client server`
|
|
+ ORBIT_LIBS=`$ORBIT_CONFIG --use-service=name --libs client server`
|
|
|
|
|
|
else
|