pkgsrc/sysutils/xplr/patches/patch-Cargo.toml
pin b1bbf44754 sysutils/xplr: update to 0.19.3
v0.19.3
 - Bug fixes for passing filters using the --on-load argument.

v0.19.2
 - Fixed support for the following keys in input mode:
    ctrl-h
    ctrl-b
    ctrl-f
    home
    end
    ctrl-k

v0.19.1
 - You can now access uid and gid of the file owners in the Lua API. See
   column-renderer and node docs.
 - The input buffer will support more readline-like keys. Also, added
   "DeleteTillEnd" as another cursor based "InputOperation" option.
   See tui-input v0.5.0 release.
 - Fixed applying regex based filters via the CLI and $XPLR_PIPE_MSG_IN pipe.
   See issue #503.
 - You can use the prompt field to define input prompt for each mode, instead
   of using the SetInputPrompt message. See init.lua changes.
2022-09-11 11:36:15 +00:00

15 lines
412 B
TOML

$NetBSD: patch-Cargo.toml,v 1.18 2022/09/11 11:36:15 pin Exp $
Don't pull vendored version, use pkgsrc LuaJIT2
--- Cargo.toml.orig 2022-09-11 02:46:38.000000000 +0000
+++ Cargo.toml
@@ -63,7 +63,7 @@ features = ['serde']
[dependencies.mlua]
version = "0.8.3"
-features = ['luajit', 'vendored', 'serialize', 'send']
+features = ['luajit', 'serialize', 'send']
[dependencies.tui-input]
version = "0.5.1"