e09fdcb614
The following bugs have been fixed in NSS 3.11.4. * Bug 115951: freebl dynamic library is never unloaded by libsoftoken or libssl. Also tiny one-time leak in freebl's loader.c. * Bug 127960: SSL force handshake function should take a timeout. * Bug 335454: Unable to find library 'libsoftokn3.sl' on HP-UX 64 bit. * Bug 350200: Implement DHMAC based POP (ProofOfPossession). * Bug 351482: audit_log_user_message doesn't exist in all versions of libaudit.so.0. (the "paranoia patch") * Bug 352041: oom [@ CERT_DecodeDERCrlWithFlags] "extended" tracked as NULL was dereferenced. * Bug 353422: Klocwork bugs in nss/lib/crmf. * Bug 353475: Cannot run cmd tools compiled with VC++ 2005. * Bug 353572: leak in sftk_OpenCertDB. * Bug 353608: NSS_RegisterShutdown may fail, and appData argument to callbacks is always NULL. * Bug 353749: PowerUpSelf tests update for DSA and ECDSA KAT. * Bug 353896: Building tip with NSS_ECC_MORE_THAN_SUITE_B causes crashes in all.sh. * Bug 353910: memory leak in RNG_RNGInit. * Bug 354313: STAN_GetCERTCertificateName leaks "instance" struct. * Bug 354384: vfyserv shutdown failure when client auth requested. * Bug 354900: Audit modifications, accesses, deletions, and additions of cryptographic keys. * Bug 355297: Improve the very first RNG_RandomUpdate call. * Bug 356073: C_GetTokenInfo should return CKR_CRYPTOKI_NOT_INITIALIZED if not initialized. * Bug 356309: CertVerifyLog in CERT_VerifyCertificate terminates early on expired certs. * Bug 357197: OCSP response code fails to match CERTIds. (hot fix only) * Bug 359484: FireFox 2 tries to negotiate ECC cipher suites using ssl2 client hello. (hot fix only) * Bug 360818: No RPATH set for signtool and signver.
21 lines
693 B
Text
21 lines
693 B
Text
$NetBSD: patch-ae,v 1.5 2007/01/20 18:55:09 wiz Exp $
|
|
|
|
--- mozilla/security/nss/cmd/platlibs.mk.orig 2006-11-17 02:13:16.000000000 +0000
|
|
+++ mozilla/security/nss/cmd/platlibs.mk
|
|
@@ -213,7 +213,7 @@ endif
|
|
# If GNU ld is used, we must use the -rpath-link option to tell
|
|
# the linker where to find libsoftokn3.so, an implicit dependency
|
|
# of libnss3.so.
|
|
-ifeq (,$(filter-out BSD_OS FreeBSD Linux NetBSD, $(OS_ARCH)))
|
|
+ifeq (,$(filter-out BSD_OS FreeBSD Linux NetBSD DragonFly, $(OS_ARCH)))
|
|
EXTRA_SHARED_LIBS += -Wl,-rpath-link,$(DIST)/lib
|
|
endif
|
|
|
|
@@ -236,6 +236,7 @@ EXTRA_SHARED_LIBS += \
|
|
-L$(DIST)/lib \
|
|
-lssl3 \
|
|
-lsmime3 \
|
|
+ -lsoftokn3 \
|
|
-lnss3 \
|
|
-L$(NSPR_LIB_DIR) \
|
|
-lplc4 \
|