pkgsrc/lang/gcc3/patches/patch-ag
seb 1cd5dcea8a Make all gcc3-* packages use a single distinfo file from gcc3/distinfo and
a single patch directory from gcc3/patches/.
Also Move gcc3-c/{Makefile.common,language.mk} into gcc3/.
2004-04-10 15:47:08 +00:00

13 lines
445 B
Text

$NetBSD: patch-ag,v 1.3 2004/04/10 15:47:08 seb Exp $
Index: gcc/config/netbsd.h
--- gcc/config/netbsd.h Wed Jul 23 02:41:37 2003
+++ gcc/config/netbsd.h Fri Jul 25 17:57:43 2003
@@ -234,3 +234,7 @@
/* 7 == PROT_READ | PROT_WRITE | PROT_EXEC */ \
(void) mprotect (page, end - page, 7); \
}
+
+/* NetBSD depends on "cpp" having GNUC semantics, and must default as if
+ "cpp -gcc" was called. */
+#define DEFAULT_CPP_NEED_NO_GCC 0