pkgsrc/devel/boehm-gc/patches/patch-aa
wiz 141eb08c3d Update to 7.0:
Changes relative to 6.8 include, in no particular order:

 - Change C code to require at least C89.  Clean up code in various
   other respects.
 - Win64 port.
 - Always count how much live data there is in the heap.  Add more
   robust heap expansion heuristic which relies on this.
 - Remove old-style Solaris threads support and some other obsolete
   platform support.
 - Restructure mark code, hopefully resulting in some performance
   improvements.
 - Change the GC code to traffic mostly in either bytes or allocation
   granules, not words, internally.
 - Provide for fast inline allocation that requires less frequent client
   recompilations.  (Needs more testing.)
 - Removed SILENT configuration macro and PRINTSTATS and GATHERSTATS
   macros.  Control is now via GC_PRINT_STATS and GC_PRINT_VERBOSE_STATS
   encironment variables.
 - Thread local allocation is now performed without needing to call
   special allocation functions.  The configuration macro
   THREAD_LOCAL_ALLOC
   continues to determine whether this is supported.
 - Thread local allocation is supported on more platforms.
 - Win32 threads code was rewritten and is hopefully more sane.
 - Allocation routines now decide whether to lock dynamically, based on
   whether a second thread has been created.
 - Mostly untested support for a compiler write barrier.
 - Use libatomic_ops for atomic operations.
 - Limited support for malloc redirection with Linux threads (& NPTL ).
 - Various bug fixes and some new platform support.
2007-07-07 15:21:07 +00:00

13 lines
369 B
Text

$NetBSD: patch-aa,v 1.19 2007/07/07 15:21:07 wiz Exp $
--- configure.ac.orig 2007-06-30 15:40:15.000000000 +0000
+++ configure.ac
@@ -399,7 +399,7 @@ case "$host" in
machdep="mach_dep.lo sparc_mach_dep.lo"
AC_DEFINE(SUNOS53_SHARED_LIB)
;;
- sparc*-sun-solaris2.*)
+ sparc*-sun-solaris2*)
machdep="mach_dep.lo sparc_mach_dep.lo"
;;
ia64-*-*)