a26a086ead
Upstream changes: OpenDNSSEC 2.1.9 - 2021-05-03 * OPENDNSSEC-955: Prevent concurrency between C_Login/C_OpenSession and C_FindObject in PKCS#11 operations as some HSMs do not like this and the key may (transiently) not be available. * OPENDNSSEC-956: Harden the signing procedure to still sign zones for which there are unused keys specified in the signconf. These are included by the enforcer because there may be (outdated) signatures for them, but the signer doesn't need this reference anymore in 2.1. However this was left in for backwards compatibility (probably).
46 lines
2.9 KiB
Text
46 lines
2.9 KiB
Text
$NetBSD: patch-conf_Makefile.in,v 1.2 2021/05/04 07:37:19 he Exp $
|
|
|
|
Install configs in example config directory.
|
|
|
|
--- conf/Makefile.in.orig 2017-08-10 12:03:23.000000000 +0000
|
|
+++ conf/Makefile.in
|
|
@@ -399,6 +399,7 @@ sbindir = @sbindir@
|
|
sharedstatedir = @sharedstatedir@
|
|
srcdir = @srcdir@
|
|
sysconfdir = @sysconfdir@/opendnssec
|
|
+EGDIR=@EGDIR@
|
|
target = @target@
|
|
target_alias = @target_alias@
|
|
target_cpu = @target_cpu@
|
|
@@ -679,18 +680,19 @@ regress: $(RNG)
|
|
(echo "kasp.xml built")
|
|
|
|
install-data-hook:
|
|
- test -d ${DESTDIR}${sysconfdir} || ${INSTALL_DATA} -m 0775 -d @INSTALLATIONUSERARG@ @INSTALLATIONGROUPARG@ ${DESTDIR}${sysconfdir}
|
|
- test -f ${DESTDIR}${sysconfdir}/conf.xml || ( ${INSTALL_DATA} -m 0640 conf.xml @INSTALLATIONUSERARG@ @INSTALLATIONGROUPARG@ ${DESTDIR}${sysconfdir} ; if which >/dev/null xmlif ; then xmlif < ${DESTDIR}${sysconfdir}/conf.xml > ${DESTDIR}${sysconfdir}/conf.xml~ privdrop=@INSTALLATIONCOND@ ; else ${GREP} -v '^<?xmlif' < ${DESTDIR}${sysconfdir}/conf.xml > ${DESTDIR}${sysconfdir}/conf.xml~ ; fi ; cat < ${DESTDIR}${sysconfdir}/conf.xml~ > ${DESTDIR}${sysconfdir}/conf.xml ; rm ${DESTDIR}${sysconfdir}/conf.xml~ )
|
|
- ${INSTALL_DATA} -m 640 conf.xml ${DESTDIR}${sysconfdir}/conf.xml.sample ; ${GREP} -v '^<?xmlif' < ${DESTDIR}${sysconfdir}/conf.xml.sample > ${DESTDIR}${sysconfdir}/conf.xml.sample~ ; cat < ${DESTDIR}${sysconfdir}/conf.xml.sample~ > ${DESTDIR}${sysconfdir}/conf.xml.sample ; rm ${DESTDIR}${sysconfdir}/conf.xml.sample~
|
|
- test -f ${DESTDIR}${sysconfdir}/addns.xml || \
|
|
- ${INSTALL_DATA} @INSTALLATIONUSERARG@ @INSTALLATIONGROUPARG@ addns.xml ${DESTDIR}${sysconfdir}
|
|
- ${INSTALL_DATA} addns.xml ${DESTDIR}${sysconfdir}/addns.xml.sample
|
|
- test -f ${DESTDIR}${sysconfdir}/zonelist.xml || \
|
|
- ${INSTALL_DATA} @INSTALLATIONUSERARG@ @INSTALLATIONGROUPARG@ zonelist.xml ${DESTDIR}${sysconfdir}
|
|
- ${INSTALL_DATA} zonelist.xml ${DESTDIR}${sysconfdir}/zonelist.xml.sample
|
|
- test -f ${DESTDIR}${sysconfdir}/kasp.xml || \
|
|
- ${INSTALL_DATA} @INSTALLATIONUSERARG@ @INSTALLATIONGROUPARG@ kasp.xml ${DESTDIR}${sysconfdir}
|
|
- ${INSTALL_DATA} kasp.xml ${DESTDIR}${sysconfdir}/kasp.xml.sample
|
|
+ test -d ${DESTDIR}${EGDIR} || mkdir -p ${DESTDIR}${EGDIR}
|
|
+ test -f ${DESTDIR}${EGDIR}/conf.xml || \
|
|
+ ${INSTALL_DATA} -m 0640 conf.xml ${DESTDIR}${EGDIR}
|
|
+ ${INSTALL_DATA} -m 640 conf.xml ${DESTDIR}${EGDIR}/conf.xml.sample
|
|
+ test -f ${DESTDIR}${EGDIR}/addns.xml || \
|
|
+ ${INSTALL_DATA} addns.xml ${DESTDIR}${EGDIR}
|
|
+ ${INSTALL_DATA} addns.xml ${DESTDIR}${EGDIR}/addns.xml.sample
|
|
+ test -f ${DESTDIR}${EGDIR}/zonelist.xml || \
|
|
+ ${INSTALL_DATA} zonelist.xml ${DESTDIR}${EGDIR}
|
|
+ ${INSTALL_DATA} zonelist.xml ${DESTDIR}${EGDIR}/zonelist.xml.sample
|
|
+ test -f ${DESTDIR}${EGDIR}/kasp.xml || \
|
|
+ ${INSTALL_DATA} kasp.xml ${DESTDIR}${EGDIR}
|
|
+ ${INSTALL_DATA} kasp.xml ${DESTDIR}${EGDIR}/kasp.xml.sample
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|