This version has a real master site and homepage at sourceforge. Includes updates for buildling with the latest png api and fixes to debug.c (patch-ai). Removed the patches for this. Removed patch-ab, patch-ac and patch-ae because we only build the lib. Other updates upstream: Support for utf-8 text and xft. Function XmHTMLScrollToYPos added. Fixes for crashes and various memory leaks.
13 lines
427 B
Text
13 lines
427 B
Text
$NetBSD: patch-af,v 1.5 2019/09/06 08:46:26 nros Exp $
|
|
* use libtool
|
|
--- lib/common/Makefile.orig Mon Mar 5 13:37:18 2001
|
|
+++ lib/common/Makefile
|
|
@@ -56,7 +56,7 @@
|
|
# rule to create .o files from .c files
|
|
.c.o:
|
|
$(RM) $@
|
|
- $(CC) $(CFLAGS) -DVERSION=$(VERSION) $(CPPFLAGS) $(INCLUDES) -c $<
|
|
+ ${LIBTOOL} --mode=compile $(CC) $(CFLAGS) -DVERSION=$(VERSION) $(CPPFLAGS) $(INCLUDES) -c $<
|
|
|
|
# targets to build
|
|
all: $(TARGET)
|