7938e04ade
version, so I'm not including the entire changelog here; see the package changelog for more details. The patch was originally submitted by Francois Tigeot as PR pkg/46156 - I've updated it since.
32 lines
1.1 KiB
Text
32 lines
1.1 KiB
Text
$NetBSD: patch-src_contribs-lib_CMakeLists.txt,v 1.1 2013/08/11 16:06:25 jaapb Exp $
|
|
|
|
Install contribs-lib if built.
|
|
--- src/contribs-lib/CMakeLists.txt.orig 2011-03-17 00:21:07.000000000 +0000
|
|
+++ src/contribs-lib/CMakeLists.txt
|
|
@@ -106,9 +106,26 @@ add_library(clucene-contribs-lib SHARED
|
|
)
|
|
TARGET_LINK_LIBRARIES(clucene-contribs-lib ${clucene_contrib_extra_libs})
|
|
|
|
+#install public headers.
|
|
+FOREACH(file ${HEADERS})
|
|
+ get_filename_component(apath ${file} PATH)
|
|
+ get_filename_component(aname ${file} NAME)
|
|
+ file(RELATIVE_PATH relpath ${CMAKE_SOURCE_DIR}/src/contribs-lib ${apath})
|
|
+ IF ( NOT aname MATCHES "^_.*" )
|
|
+ install(FILES ${file}
|
|
+ DESTINATION include/${relpath}
|
|
+ COMPONENT development)
|
|
+ ENDIF ( NOT aname MATCHES "^_.*" )
|
|
+ENDFOREACH(file)
|
|
+
|
|
#set properties on the libraries
|
|
SET_TARGET_PROPERTIES(clucene-contribs-lib PROPERTIES
|
|
VERSION ${CLUCENE_VERSION}
|
|
SOVERSION ${CLUCENE_SOVERSION}
|
|
COMPILE_DEFINITIONS_DEBUG _DEBUG
|
|
)
|
|
+
|
|
+#and install library
|
|
+install(TARGETS clucene-contribs-lib
|
|
+ DESTINATION ${LIB_DESTINATION}
|
|
+ COMPONENT runtime )
|