2b58a261c8
Add DragonFly support. Derived from Firefox patches.
88 lines
2.7 KiB
Text
88 lines
2.7 KiB
Text
$NetBSD: patch-do,v 1.1 2006/06/28 21:23:29 joerg Exp $
|
|
|
|
diff -ruN ../Orig/mozilla/directory/c-sdk/config/DragonFly.mk ./directory/c-sdk/config/DragonFly.mk
|
|
--- ../Orig/mozilla/directory/c-sdk/config/DragonFly.mk 1970-01-01 09:00:00.000000000 +0900
|
|
+++ ./directory/c-sdk/config/DragonFly.mk 2005-12-04 19:44:55.000000000 +0900
|
|
@@ -0,0 +1,82 @@
|
|
+#
|
|
+# The contents of this file are subject to the Mozilla Public
|
|
+# License Version 1.1 (the "License"); you may not use this file
|
|
+# except in compliance with the License. You may obtain a copy of
|
|
+# the License at http://www.mozilla.org/MPL/
|
|
+#
|
|
+# Software distributed under the License is distributed on an "AS
|
|
+# IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
|
|
+# implied. See the License for the specific language governing
|
|
+# rights and limitations under the License.
|
|
+#
|
|
+# The Original Code is the Netscape Portable Runtime (NSPR).
|
|
+#
|
|
+# The Initial Developer of the Original Code is Netscape
|
|
+# Communications Corporation. Portions created by Netscape are
|
|
+# Copyright (C) 1998-2000 Netscape Communications Corporation. All
|
|
+# Rights Reserved.
|
|
+#
|
|
+# Contributor(s):
|
|
+#
|
|
+# Alternatively, the contents of this file may be used under the
|
|
+# terms of the GNU General Public License Version 2 or later (the
|
|
+# "GPL"), in which case the provisions of the GPL are applicable
|
|
+# instead of those above. If you wish to allow use of your
|
|
+# version of this file only under the terms of the GPL and not to
|
|
+# allow others to use your version of this file under the MPL,
|
|
+# indicate your decision by deleting the provisions above and
|
|
+# replace them with the notice and other provisions required by
|
|
+# the GPL. If you do not delete the provisions above, a recipient
|
|
+# may use your version of this file under either the MPL or the
|
|
+# GPL.
|
|
+#
|
|
+
|
|
+#
|
|
+# Config stuff for DragonFly
|
|
+#
|
|
+
|
|
+include $(MOD_DEPTH)/config/UNIX.mk
|
|
+
|
|
+CC = gcc
|
|
+CCC = g++
|
|
+RANLIB = ranlib
|
|
+
|
|
+OS_REL_CFLAGS = -Di386
|
|
+CPU_ARCH = x86
|
|
+CPU_ARCH_TAG = _$(CPU_ARCH)
|
|
+
|
|
+OS_CFLAGS = $(DSO_CFLAGS) $(OS_REL_CFLAGS) -ansi -Wall -pipe $(THREAD_FLAG) -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
|
|
+
|
|
+#
|
|
+# The default implementation strategy for FreeBSD is pthreads.
|
|
+#
|
|
+ifeq ($(CLASSIC_NSPR),1)
|
|
+IMPL_STRATEGY = _EMU
|
|
+DEFINES += -D_PR_LOCAL_THREADS_ONLY
|
|
+else
|
|
+USE_PTHREADS = 1
|
|
+IMPL_STRATEGY = _PTH
|
|
+DEFINES += -D_THREAD_SAFE
|
|
+THREAD_FLAG += -pthread
|
|
+endif
|
|
+
|
|
+ARCH = freebsd
|
|
+
|
|
+MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
|
|
+
|
|
+ifeq ($(MOZ_OBJFORMAT),elf)
|
|
+DLL_SUFFIX = so
|
|
+else
|
|
+DLL_SUFFIX = so.1.0
|
|
+endif
|
|
+
|
|
+DSO_CFLAGS = -fPIC
|
|
+DSO_LDOPTS = -Bshareable
|
|
+
|
|
+ifdef LIBRUNPATH
|
|
+DSO_LDOPTS += -Wl,-R$(LIBRUNPATH)
|
|
+endif
|
|
+
|
|
+MKSHLIB = $(LD) $(DSO_LDOPTS)
|
|
+
|
|
+G++INCLUDES = -I/usr/include/g++
|