pkgsrc/cross/nios2-binutils/patches/patch-ag
mef 14bb9862e2 (pkgsrc)
Switch from Codesourcery to GNU FSF
(Upstream 2.23.2 to 2.24.0)
- binutils
  * Objcopy now supports wildcard characters in command line options that take
    section names.
  * Add support for Altera Nios II.
- gas
  * Add support for the Texas Instruments MSP430X processor.
  * Add -gdwarf-sections command line option to enable per-code-section
    generation of DWARF .debug_line sections.
  * Add support for Altera Nios II.
  * Add support for the Imagination Technologies Meta processor.
  * Add support for the v850e3v5.
  * Remove assembler support for MIPS ECOFF targets.
- ld
  * Add LOG2CEIL() builtin function to the linker script language
  * Add support for the Texas Instruments MSP430X processor.
  * Add support for Altera Nios II.
  * Add support for the V850E3V5 architecture.
  * Add support for the Imagination Technologies Meta processor.
  * --enable-new-dtags no longer generates old dtags in addition to new dtags.
  * Remove linker support for MIPS ECOFF targets.
  * Add ALIGN_WITH_INPUT to the linker script language to force the alignment of
    an output section to use the maximum alignment of all its input sections.
2014-06-15 23:43:13 +00:00

24 lines
859 B
Text

$NetBSD: patch-ag,v 1.1 2014/06/15 23:43:14 mef Exp $
Avoid installing info (which duplicates with other CPU)
--- ld/Makefile.in.orig 2012-09-04 21:53:47.000000000 +0900
+++ ld/Makefile.in 2013-01-27 07:19:44.000000000 +0900
@@ -118,7 +118,7 @@ LTYACCCOMPILE = $(LIBTOOL) $(AM_LIBTOOLF
--mode=compile $(YACC) $(YFLAGS) $(AM_YFLAGS)
SOURCES = $(libldtestplug_la_SOURCES) $(ld_new_SOURCES) \
$(EXTRA_ld_new_SOURCES)
-INFO_DEPS = ld.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)/../texinfo
DVIS = ld.dvi
PDFS = ld.pdf
@@ -345,7 +345,7 @@ use_sysroot = @use_sysroot@
AUTOMAKE_OPTIONS = dejagnu no-texinfo.tex no-dist foreign
ACLOCAL_AMFLAGS = -I .. -I ../config -I ../bfd
TEXINFO_TEX = ../texinfo/texinfo.tex
-SUBDIRS = po
+SUBDIRS =
tooldir = $(exec_prefix)/$(target_alias)
# Automake 1.10+ disables lex and yacc output file regeneration if