3d7c9445c0
* [SECURITY] Fix bug in encoding of usernames that contain '='. This fixes the security advisories noted here: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2659 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=368834 http://secunia.com/advisories/20519/ * Implemented "Purge" option for mail filters. * Invoke Courier filters in alphabetical order, and uses 050 exit code to accept a message without running the remaining filters, which gets converted to a 250 ESMTP code. * Fix improper parsing of ident/pfix tokens in SPF. * New command line tool "aliaslookup" to look up mail aliases. * Added support for the koi8-u character set.
108 lines
3.1 KiB
Text
108 lines
3.1 KiB
Text
$NetBSD: patch-ac,v 1.2 2006/06/09 22:12:18 jlam Exp $
|
|
|
|
--- courier/doc/Makefile.in.orig 2006-04-12 19:26:24.000000000 -0400
|
|
+++ courier/doc/Makefile.in
|
|
@@ -141,7 +141,7 @@ target_alias = @target_alias@
|
|
version = @version@
|
|
htmldocdir = @datadir@/htmldoc
|
|
CLEANFILES = permissions.dat
|
|
-miscfiles = japanese_flag.png bg.gif icon.gif manpage.css \
|
|
+miscfiles = japanese_flag.png bg.gif icon.gif \
|
|
draft-varshavchik-exdata-smtpext.txt \
|
|
draft-varshavchik-verp-smtpext.txt \
|
|
draft-varshavchik-security-smtpext.txt \
|
|
@@ -179,65 +179,37 @@ htmlin = \
|
|
courier.html \
|
|
courierldapaliasd.html \
|
|
couriermlm.html \
|
|
- courierpop3d.html \
|
|
- couriertcpd.html \
|
|
- couriertls.html \
|
|
- deliverquota.html \
|
|
dot-courier.html \
|
|
dot-forward.html \
|
|
esmtpd.html \
|
|
- imapd.html \
|
|
localmailfilter.html \
|
|
- lockmail.html \
|
|
- mailbot.html \
|
|
- maildiracl.html \
|
|
- maildir.html \
|
|
- maildirkw.html \
|
|
- maildirmake.html \
|
|
- maildirquota.html \
|
|
- maildropex.html \
|
|
- maildropfilter.html \
|
|
- maildropgdbm.html \
|
|
- maildrop.html \
|
|
- maildrop.README.html \
|
|
- maildroptips.html \
|
|
mailq.html \
|
|
makeacceptmailfor.html \
|
|
makealiases.html \
|
|
- makedat.html \
|
|
makehosteddomains.html \
|
|
- makemime.html \
|
|
makepercentrelay.html \
|
|
makesmtpaccess.html \
|
|
- mimegpg.html \
|
|
mkesmtpdcert.html \
|
|
- mkimapdcert.html \
|
|
- mkpop3dcert.html \
|
|
- pcp_README.html \
|
|
pop3d.html \
|
|
preline.html \
|
|
- reformail.html \
|
|
- reformime.html \
|
|
sendmail.html \
|
|
submit.html \
|
|
testmxlookup.html
|
|
|
|
htmldoc_DATA = $(nohtmlin) $(htmlin)
|
|
-man1 = sendmail.1 preline.1 maildirmake.1 cancelmsg.1 lockmail.1 maildrop.1 \
|
|
- mailq.1 mailbot.1 makemime.1 mimegpg.1 maildiracl.1 \
|
|
- makedat.1 reformail.1 reformime.1 couriermlm.1 testmxlookup.1 \
|
|
- dot-forward.1 couriertls.1 couriertcpd.1 maildirkw.1
|
|
-
|
|
-man5 = dot-courier.5 maildir.5
|
|
-man7 = localmailfilter.7 maildirquota.7 maildropgdbm.7 maildropfilter.7 \
|
|
- maildropex.7
|
|
+man1 = sendmail.1 preline.1 cancelmsg.1 \
|
|
+ mailq.1 \
|
|
+ couriermlm.1 testmxlookup.1 \
|
|
+ dot-forward.1
|
|
|
|
-man8 = aliaslookup.8 courier.8 courierldapaliasd.8 courierpop3d.8 \
|
|
- deliverquota.8 \
|
|
+man5 = dot-courier.5
|
|
+man7 = localmailfilter.7
|
|
+
|
|
+man8 = aliaslookup.8 courier.8 courierldapaliasd.8 \
|
|
esmtpd.8 makeacceptmailfor.8 makehosteddomains.8\
|
|
- mkesmtpdcert.8 mkimapdcert.8 mkpop3dcert.8 \
|
|
+ mkesmtpdcert.8 \
|
|
makealiases.8 makepercentrelay.8 makesmtpaccess.8 \
|
|
- pop3d.8 submit.8 imapd.8
|
|
+ pop3d.8 submit.8
|
|
|
|
BUILT_SOURCES = \
|
|
aliaslookup.html aliaslookup.8 \
|
|
@@ -263,7 +235,7 @@ BUILT_SOURCES = \
|
|
testmxlookup.html testmxlookup.1
|
|
|
|
EXTRA_DIST = $(nohtmlin) $(BUILT_SOURCES)
|
|
-man_LINKS = $(man8dir)/courierpop3login.8 \
|
|
+man_LINKS = \
|
|
$(man1dir)/rmail.1 $(man1dir)/dotforward.1 \
|
|
$(man8dir)/makesmtpaccess-msa.8 \
|
|
$(man8dir)/esmtpd-msa.8
|
|
@@ -1125,8 +1097,7 @@ preline.1: preline.1.in
|
|
|
|
install-man-extra:
|
|
cd $(DESTDIR)$(man8dir) ; \
|
|
- rm -f courierpop3login.8 makesmtpaccess-msa.8 esmtpd-msa.8; \
|
|
- $(LN_S) courierpop3d.8 courierpop3login.8; \
|
|
+ rm -f makesmtpaccess-msa.8 esmtpd-msa.8; \
|
|
$(LN_S) makesmtpaccess.8 makesmtpaccess-msa.8 ; \
|
|
$(LN_S) esmtpd.8 esmtpd-msa.8
|
|
cd $(DESTDIR)$(man1dir) ; rm -f rmail.1 dotforward.1 \
|