pkgsrc/graphics/netpbm/patches/patch-ab
wiz 5d908a3ef0 Add a patch that disables optimization for one file; otherwise
an ICE would result with gcc-3.3.x on sparc64.  See PR 23124.
Patch from jdc@.
2004-03-22 15:52:35 +00:00

18 lines
529 B
Text

$NetBSD: patch-ab,v 1.13 2004/03/22 15:52:35 wiz Exp $
--- converter/other/Makefile.orig Wed Jan 8 22:52:23 2003
+++ converter/other/Makefile
@@ -94,6 +94,13 @@ HEADERLINKS = pm_config.h pm.h pbm.h pgm
include $(SRCDIR)/Makefile.common
+# XXX sparc64 gcc 3.3.x toolchain bug means we must compile exif.o without
+# optimisation
+EXIF_CFLAGS=$(CFLAGS:-O2=)
+exif.o: exif.c
+ $(CC) -c -I$(SRCDIR)/$(SUBDIR) -I. $(INCLUDES) \
+ $(EXIF_CFLAGS) $(CADD) -o $@ $<
+
ifeq ($(NEED_RUNTIME_PATH),Y)
LIBOPTR = -runtime
else