pkgsrc/lang/ghc/patches/patch-aq
augustss 5012e7fbb4 Update to a new GHC. There are too numerous changes to mention; see the
GHC documentation for details.

The most import change is that this package (which has been broken since the
conversion from a.out to ELF) has been re-ported to NetBSD by Urban Boquist,
boquist@crt.se.
2003-04-29 11:27:39 +00:00

64 lines
1.8 KiB
Text

$NetBSD: patch-aq,v 1.1 2003/04/29 11:27:49 augustss Exp $
--- configure.in.orig Mon Feb 17 12:27:20 2003
+++ configure.in Sun Mar 30 11:46:08 2003
@@ -718,6 +718,13 @@
fi
AC_SUBST(HaveReadlineHeaders)
+dnl ** XXX_UB: fix this in a better way!
+ReadlineIncludePath=
+if test x"$TargetOS_CPP" = x"netbsd"; then
+ ReadlineIncludePath=@PREFIX@/include
+fi
+AC_SUBST(ReadlineIncludePath)
+
dnl ** check for DOS include files
AC_CHECK_HEADERS(dos.h conio.h io.h std.h)
@@ -734,14 +741,14 @@
AC_CHECK_HEADERS(dlfcn.h dl.h)
dnl ** check for farcalloc (in bcc)
-AC_CHECK_HEADER(alloc.h,AC_CHECK_FUNCS(farcalloc))
+AC_CHECK_HEADER(alloc.h,[AC_CHECK_FUNCS(farcalloc)])
dnl ** check for valloc (in sunos, solaris, mips, amiga, next, minix, ultrix)
-AC_CHECK_HEADER(malloc.h,AC_CHECK_FUNCS(valloc))
+AC_CHECK_HEADER(malloc.h,[AC_CHECK_FUNCS(valloc)])
dnl ** check for POSIX regex
HavePosixRegex=NO
-AC_CHECK_HEADER(regex.h,AC_CHECK_FUNC(regcomp, HavePosixRegex=YES))
+AC_CHECK_HEADER(regex.h,[AC_CHECK_FUNC(regcomp, HavePosixRegex=YES)])
AC_SUBST(HavePosixRegex)
dnl ** how do we get a timezone name, and UTC offset ?
@@ -942,6 +949,13 @@
AC_SUBST(HaveLibGmp)
AC_SUBST(LibGmp)
+dnl ** XXX_UB: fix this in a better way!
+ExtraLdOptsGmp=
+if test x"$TargetOS_CPP" = x"netbsd"; then
+ ExtraLdOptsGmp="-L@PREFIX@/lib -Wl,-R@PREFIX@/lib"
+fi
+AC_SUBST(ExtraLdOptsGmp)
+
dnl ** (Mac OS X only: check for HaskellSupport.framework)
HaveFrameworkHaskellSupport=NO
if test $HostPlatform = "powerpc-apple-darwin"; then
@@ -1012,6 +1026,13 @@
AC_DEFINE(HAVE_READLINE_4, 0)
AC_DEFINE(HAVE_READLINE_4_2, 0)
fi
+
+dnl ** XXX_UB: fix this in a better way!
+ExtraLdOptsReadline=
+if test x"$TargetOS_CPP" = x"netbsd"; then
+ ExtraLdOptsReadline="-L@PREFIX@/lib -Wl,-R@PREFIX@/lib"
+fi
+AC_SUBST(ExtraLdOptsReadline)
dnl ** check for math library
FPTOOLS_CHECK_LIBM()