e1339d6190
Bugfixes: * compile: multiple fixes isnan and isinf defines to make rrdtool compile with gcc on solaris (with --disable-nls) * handle gettext/libintl like any other feature, do not try to supply our own ... rrdtool can work fine without it * rrd_client: fix potential segfaults * rrd_client: resolve synmlinks properly * compile: fix libtool and libtoolize names for OSX compiles * compile: fix for HAVE_BROKEN_MS_ASYNC (old linux kernels) * rrd_xport: fix --daemon handling * rrd_client: explicitly close connection on error * rrd_update: fix memory leak for COMPUTE datasources * rrd_daemon: fix segfault when specifying a relative path (-j option) * compile: make rrdtool compile with gcc 4.5 * portability: use %lld (long long int) for time_t *printf * compile: link pangocairo and not pango since we do use pangocairo actually * compile: re-integrate intl into compile dependency so that hosts with old (or no) gettext can get access to the included copy. * rrd_cached: exit with status !=0 on invalid cli Enhancements: * updated build files and instructions for win32 port by Chris Larsen * legal: Relicense the RRDCacheD client interface under the MIT license * legal: Updted FLOSS Exception for latest PHP license * rrd_cached: better help output
15 lines
552 B
Text
15 lines
552 B
Text
$NetBSD: patch-am,v 1.8 2010/07/06 07:31:37 adam Exp $
|
|
|
|
Correct examples directory.
|
|
|
|
--- examples/rrdcached/Makefile.in.orig 2010-07-06 07:23:46.000000000 +0000
|
|
+++ examples/rrdcached/Makefile.in
|
|
@@ -283,7 +283,7 @@ target_vendor = @target_vendor@
|
|
top_build_prefix = @top_build_prefix@
|
|
top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
-examplesdir = $(pkgdatadir)/examples/rrdcached
|
|
+examplesdir = $(prefix)/share/examples/rrdcached
|
|
examples_SCRIPTS = RRDCached.pm rrdcached-size.pl
|
|
EXTRA_DIST = RRDCached.pm rrdcached-size.pl
|
|
all: all-am
|