c4354bc45b
Changes between PTL2-current-990622 and PTL-2.1.2 * support NetBSD/arm32. * fix a configure.in bug which fails if $MACHINE != $MACHINE_ARCH. * src/io_udp.c (send_timedwait, sendto_timedwait, sendmsg_timedait): While underlying system calls return with EWOULDBLOCK, continue writing. * src/signal.c (_pthread_signal_init): On system that PTL can set the stack pointer without using sigstack(), SIGUSR2 can be used for user's purpose. * src/internal.h (END_CRITICAL): fixed: signal interruptions are lost in certain situation theoretically. * src/io.c: use O_NONBLOCK rather than O_NDELAY in SunOS5. * Util/Makefile.in: version number of libPTL.so is changed to 2.0. * src/specific.c (pthread_key_create, pthread_setspecific): if fail to allocate the memory, returns ENOMEM. * src/cond.c, src/mutex.c, include/sys/types.h: pthread_mutex_t and pthread_cond_t are changed from `pointer to struct' to `struct'. * src/cond-attr.c, include/sys/types.h: pthread_condattr_t is changed from integer handle to struct. * src/cond.c, src/mutex.c, src/pthread.c: pthread_{mutex_,cond_,}setname_np returns ENOMEM if malloc() returns NULL. * src/cancel.c (pthread_setcancelstate): if FLAG_CLEANUP_HANDLER is set, do not call pthread_exit() even if PTHREAD_CANCEL_ENABLE is specified and the thread is already cancel requested. (pthread_testcancel): similar to above. * src/internal.h (FLAG_CLEANUP_HANDLER): this flag shows that the thread is currently executing cleanup handlers. * src/sched.c (after_csw): Clear FLAG_DO_CANCEL flag before executing cleanup handlers to prevent entering executing cleanup handlers loop. * src/io.c (_pthread_pdb_iostat): Implement `iostat' command into PDB.
19 lines
569 B
Text
19 lines
569 B
Text
$NetBSD: patch-aa,v 1.2 2000/05/07 11:18:20 msaitoh Exp $
|
|
--- Makefile.orig Wed Mar 24 13:33:28 1999
|
|
+++ Makefile Thu Mar 25 01:03:04 1999
|
|
@@ -7,13 +7,13 @@
|
|
#
|
|
|
|
# Install directory
|
|
-prefix = /usr/local
|
|
+prefix = ${PREFIX}
|
|
exec_prefix = $(prefix)
|
|
|
|
# Directory to install ptlgcc
|
|
dest_bindir = $(exec_prefix)/bin
|
|
# Directory to install libPTL.a and libPTL.so
|
|
-dest_libdir = $(exec_prefix)/PTL/lib
|
|
+dest_libdir = $(exec_prefix)/lib
|
|
# Directory to install include files
|
|
# This directory must NOT be /usr/local/include
|
|
dest_includedir = $(exec_prefix)/PTL/include
|