pkgsrc/security/mit-krb5/patches/patch-ac
joerg 2cd7bd2623 Apply some sense to the build system by always linking the .la archives
in src/lib as that is the location it wants to pick it up. Work around
the dependencies in other places by symlinking to that, effectively
reverting the direction. Link telnet(d) consistently. Add DESTDIR support.
2010-03-26 21:44:59 +00:00

15 lines
622 B
Text

$NetBSD: patch-ac,v 1.3 2010/03/26 21:44:59 joerg Exp $
--- appl/telnet/telnetd/Makefile.in.orig 2004-09-22 18:59:45.000000000 -0400
+++ appl/telnet/telnetd/Makefile.in
@@ -60,8 +60,8 @@ OBJS= telnetd.o \
all:: telnetd
-telnetd: $(OBJS) $(PTY_DEPLIB) $(KRB4COMPAT_DEPLIBS) ../libtelnet/libtelnet.a
- $(CC_LINK) -o $@ $(OBJS) ../libtelnet/libtelnet.a $(PTY_LIB) $(UTIL_LIB) $(KRB4COMPAT_LIBS)
+telnetd: $(OBJS) $(PTY_DEPLIB) $(KRB4COMPAT_DEPLIBS) ../../../lib/libtelnet$(DEPSTLIBEXT)
+ $(CC_LINK) -o $@ $(OBJS) ../../../lib/libtelnet$(DEPSTLIBEXT) $(PTY_LIB) $(UTIL_LIB) $(KRB4COMPAT_LIBS)
clean::
$(RM) telnetd