pkgsrc/lang/caml-light/patches/patch-as
dholland 3b06c79f86 Fix broken 64-bit build. Add destdir support.
PKGREVISION++, because I changed some things around.
2008-09-05 02:07:51 +00:00

17 lines
521 B
Text

$NetBSD: patch-as,v 1.1 2008/09/05 02:07:51 dholland Exp $
destdir support.
--- lex/Makefile~ 1997-11-12 11:48:29.000000000 -0500
+++ lex/Makefile 2008-09-04 21:36:39.000000000 -0400
@@ -21,8 +21,8 @@ clean:
rm -f grammar.ml grammar.mli scanner.ml
install:
- cat $(LIBDIR)/header camllex > $(BINDIR)/camllex
- chmod a+x $(BINDIR)/camllex
+ cat $(DESTDIR)$(LIBDIR)/header camllex > $(DESTDIR)$(BINDIR)/camllex
+ chmod a+x $(DESTDIR)$(BINDIR)/camllex
grammar.ml grammar.mli: grammar.mly
$(CAMLYACC) grammar.mly