pkgsrc/graphics/libgii/patches/patch-ag
wiz 1825c7529a Update to 0.9.0:
New in 0.9.0: 2004-11-30:
- Documentation updates
- KII target improvements
    - minor fixes to button and symbol handling
    - handle labels correctly now
    - merge improvements from the FreeBSD ports tree
- works on Windows using MinGW w/o requiring special Makefiles.
- task scheduler as an abstraction for platform independent threads.
- DirectX target improvements
    - Tries to use the actual keyboard layout, and only fall back
      to the hardcoded defines when that does not work.
    - Makes shift and caps lock bring you capital letters.
    - Dead keys support (GIIK_VOID in sym, synthetic press/release
      events if non-matching key is hit after the dead key).
    - Renamed Caps, Num and Scroll to CapsLock, NumLock etc.
    - Mouse wheel support.
    - Support for up to 8 mouse buttons (2 previously).
    - Support for emPtrRelative.
    - Preliminary support for emPtrRelative.
    - Fixed a bug so that a lot of surplus emPtrAbsolute events are
      killed.
    - Support for various game controllers.
    - The mouse and the keyboard are separated into two devices.
    - Emulates key repeat messages.

New in 0.8.7: 2004-11-30:
* hotfix: input-linux-evdev: fix compiling error where KEY_103RD is not defined (SuSE 9.1)
* minor buildsystem update
* use more length bounded string operations
2005-03-25 02:46:49 +00:00

13 lines
539 B
Text

$NetBSD: patch-ag,v 1.3 2005/03/25 02:46:49 wiz Exp $
--- filter/keytrans/Makefile.in.orig 2004-11-30 21:55:59.000000000 +0100
+++ filter/keytrans/Makefile.in
@@ -256,7 +256,7 @@ keytrans_la_SOURCES = filter.c
keytrans_la_LDFLAGS = ${extra_libraries} -module -no-undefined -avoid-version \
-export-symbols ${srcdir}/EXPSYMS
-giiconfdatadir = ${sysconfdir}/${ggi_subdir}/filter
+giiconfdatadir = $(datadir)/examples/ggi/filter
giiconfdata_DATA = keytrans
filterlibdir = ${libdir}/${ggi_subdir}/filter
EXTRA_DIST = EXPSYMS keytrans