pkgsrc/emulators/pearpc/patches/patch-ac
ghen 6b9136eb08 - update pearpc to 0.4
- move options to options.mk file and reorganize a bit
- sort PLIST
- grab MAINTAINERship

ok by xtraeme.

ChangeLog for pearpc-0.4:
	- CPU: stfiwx implemented
	- config: "ppc_start_fullscreen" for starting in fullscreen mode
	- POSIX: allow bridging of tun device
	- use FISTTP instruction on SSE3 aware processors
	- merged native_cd branch from Alexander Stockinger
	- endianess fixes
	- warn that the generic CPU is slow
	- better detection of HFS+ volumes
	- support for DVD-Drives
	- correctly check for NASM
	- Work-around for graphic errors in Mac OS X 10.1
	- POSIX/Linux: fall back to 1 GHz if /proc/cpuinfo doesn't provide cpu
	  frequency
	- 3c90x emulation fixed
	- some PROM fixed for yaboot
	- alteration of x86asm interface to be more programmer friendly
	- use transparent cursors instead of altering cursor visibility (hack
	  for using PearPC with remote desktop)
	- DVD emulation implemented.  Fixes problems with Tiger installation
	- Updated the read_effective_* commands to be faster !!! REGRESSED !!!
	- fixed lvalue casts (compiles now with gcc 4.x)
	- booting from disks with bootfile about 4 GiB limit fixed
2005-12-22 19:27:36 +00:00

31 lines
899 B
Text

$NetBSD: patch-ac,v 1.1 2005/12/22 19:27:36 ghen Exp $
--- src/cpu/cpu_generic/ppc_vec.cc.orig 2005-12-21 15:41:47.000000000 +0100
+++ src/cpu/cpu_generic/ppc_vec.cc
@@ -2594,7 +2594,7 @@ void ppc_opc_vrfiz()
PPC_OPC_ASSERT(vrA==0);
for (int i=0; i<4; i++) { //FIXME: This might not comply with Java FP
- gCPU.vr[vrD].f[i] = truncf(gCPU.vr[vrD].f[i]);
+ gCPU.vr[vrD].f[i] = rint(gCPU.vr[vrD].f[i]);
}
}
@@ -2726,7 +2726,7 @@ void ppc_opc_vctsxs()
for (int i=0; i<4; i++) { //FIXME: This might not comply with Java FP
ftmp = gCPU.vr[vrB].f[i] * (float)(1 << uimm);
- ftmp = truncf(ftmp);
+ ftmp = rint(ftmp);
tmp = (sint32)ftmp;
@@ -2755,7 +2755,7 @@ void ppc_opc_vctuxs()
for (int i=0; i<4; i++) { //FIXME: This might not comply with Java FP
ftmp = gCPU.vr[vrB].f[i] * (float)(1 << uimm);
- ftmp = truncf(ftmp);
+ ftmp = rint(ftmp);
tmp = (uint32)ftmp;