+ Include termcap.buildlink3.mk because curses.so is linked against -ltermcap, so we need it to be transformed into the right library depending on the platform and PREFER_* settings. Bump the PKGREVISION to 1. + Because we are asking for ncurses (by include ncurses/buildlink3.mk), check for <ncurses.h> and -lncurses instead of <curses.h> and -lcurses. The curses.c file gets it wrong otherwise.
14 lines
534 B
Text
14 lines
534 B
Text
$NetBSD: patch-aa,v 1.2 2008/03/13 21:55:48 jlam Exp $
|
|
|
|
--- extconf.rb.orig 2007-02-12 18:01:19.000000000 -0500
|
|
+++ extconf.rb
|
|
@@ -11,9 +11,6 @@ if have_header(*curses=%w"ncurses.h") an
|
|
make=true
|
|
elsif have_header(*curses=%w"ncurses/curses.h") and have_library("ncurses", "initscr")
|
|
make=true
|
|
-elsif have_header(*curses=%w"curses_colr/curses.h") and have_library("cur_colr", "initscr")
|
|
- curses.unshift("varargs.h")
|
|
- make=true
|
|
elsif have_header(*curses=%w"curses.h") and have_library("curses", "initscr")
|
|
make=true
|
|
end
|