2d6987fab9
* The “Visual Studio 14 2015” generator has been taught about a change to the “v140” toolset made by a VS 2015 update. VS changed the set of values it understands for the “GenerateDebugInformation” linker setting that produces the “-DEBUG” linker flag variants. * “CUDA” is now supported by the Visual Studio Generators for VS 2010 and above. This complements the existing support by the Makefile Generators and the “Ninja” generator. CUDA 8.0.61 or higher is recommended due to known bugs in the VS integration by earlier versions. * CMake is now aware of the “C++ standards” and “C standards” and their associated meta-features for the following “compiler ids”: “Cray”, “PGI”, and “XL”. * The “add_library()” command “IMPORTED” option learned to support Object Libraries. * All “find_” commands now have a “PACKAGE_ROOT” search path group that is first in the search heuristics. If a “find_” command is called from inside a find module, then the CMake variable and environment variable named “_ROOT” are used as prefixes and are the first set of paths to be searched. * The “install(TARGETS)” command learned a new “OBJECTS” option to specify where to install Object Libraries. * The “install(EXPORT)” command learned how to export Object Libraries. * A “BUILD_WITH_INSTALL_NAME_DIR” target property and corresponding “CMAKE_BUILD_WITH_INSTALL_NAME_DIR” variable were added to control whether to use the “INSTALL_NAME_DIR” target property value for binaries in the build tree. This is for macOS “install_name” as “BUILD_WITH_INSTALL_RPATH” is for “RPATH”. * A “CUDA_PTX_COMPILATION” target property was added to Object Libraries to support compiling to “.ptx” files instead of host object files. * A new “GoogleTest” module was added to provide the “gtest_add_tests()” function independently of the “FindGTest” module. The function was also updated to support keyword arguments, with functionality expanded to allow a test name prefix and suffix to be specified, the dependency on the source files to be optional and the list of discovered test cases to be returned to the caller. * The “Ninja” generator has loosened the dependencies of object compilation. Object compilation now depends only on custom targets and custom commands associated with libraries on which the object’s target depends and no longer depends on the libraries themselves. Source files in dependent targets may now compile without waiting for their targets’ dependencies to link. * Interprocedural optimization (IPO) is now supported for GNU and Clang compilers using link time optimization (LTO) flags. See the “INTERPROCEDURAL_OPTIMIZATION” target property and “CheckIPOSupported” module. * The “TARGET_OBJECTS” “generator expression” is now supported by the “add_custom_command()” and “file(GENERATE)” commands.
29 lines
1.1 KiB
CMake
29 lines
1.1 KiB
CMake
$NetBSD: patch-Modules_FindPythonLibs.cmake,v 1.1 2017/07/19 17:44:34 adam Exp $
|
|
|
|
Insist on select python version for pkgsrc.
|
|
|
|
--- Modules/FindPythonLibs.cmake.orig 2014-12-15 20:07:43.000000000 +0000
|
|
+++ Modules/FindPythonLibs.cmake
|
|
@@ -82,6 +82,13 @@ else()
|
|
set(_PYTHON_FIND_OTHER_VERSIONS ${_PYTHON3_VERSIONS} ${_PYTHON2_VERSIONS} ${_PYTHON1_VERSIONS})
|
|
endif()
|
|
|
|
+# for pkgsrc: force Python version (set in pyversion.mk)
|
|
+if(DEFINED PYVERSSUFFIX)
|
|
+ set(_VERSIONS ${PYVERSSUFFIX})
|
|
+else()
|
|
+ set(_VERSIONS ${_PYTHON2_VERSIONS} ${_PYTHON3_VERSIONS})
|
|
+endif()
|
|
+
|
|
# Set up the versions we know about, in the order we will search. Always add
|
|
# the user supplied additional versions to the front.
|
|
# If FindPythonInterp has already found the major and minor version,
|
|
@@ -91,7 +98,7 @@ set(_Python_VERSIONS ${Python_ADDITIONAL
|
|
if(DEFINED PYTHON_VERSION_MAJOR AND DEFINED PYTHON_VERSION_MINOR)
|
|
list(APPEND _Python_VERSIONS ${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR})
|
|
endif()
|
|
-list(APPEND _Python_VERSIONS ${_PYTHON_FIND_OTHER_VERSIONS})
|
|
+list(APPEND _Python_VERSIONS ${_VERSIONS})
|
|
|
|
unset(_PYTHON_FIND_OTHER_VERSIONS)
|
|
unset(_PYTHON1_VERSIONS)
|