e8d0bad3df
* gpglib/list.c: Handle GnuPG 2 --with-colons output format changes. * gpglib/mimegpgfork.c: GnuPG 2 wants --batch when specifying passphrase-fd. * rfc2045/rfc2045reply.c (mkreply): Fix sender's name in the reply salutation. * html/en-us/newmsg.html: Ditto. * Big quota patch (with some changes). (See the Changelog for the previous releases) Based on patch(es) from PR pkg/42989 by Brian Candler
32 lines
1.5 KiB
Text
32 lines
1.5 KiB
Text
$NetBSD: patch-ad,v 1.11 2010/06/15 23:18:13 pettai Exp $
|
|
|
|
--- sqwebmail/Makefile.in.orig Sat Sep 29 14:53:23 2007
|
|
+++ sqwebmail/Makefile.in
|
|
@@ -1143,7 +1143,7 @@ install-perms-local: install-perms-cache
|
|
|
|
htmllibdir.h: config.status
|
|
echo '#define HTMLLIBDIR "@htmldir@"' >htmllibdir.h
|
|
- echo '#define SENDITSH "$(scriptdir)/sendit.sh"' >>htmllibdir.h
|
|
+ echo '#define SENDITSH "$(sysconfdir)/sendit.sh"' >>htmllibdir.h
|
|
echo '#define CALENDARMODE "$(sysconfdir)/calendarmode"' >>htmllibdir.h
|
|
echo '#define LOGINDOMAINLIST "$(sysconfdir)/logindomainlist"' >>htmllibdir.h
|
|
echo '#define MAXMSGSIZE @MAXMSGSIZE@' >>htmllibdir.h
|
|
@@ -1151,7 +1151,7 @@ htmllibdir.h: config.status
|
|
echo '#define SOCKDIR "$(localstatedir)"' >>htmllibdir.h
|
|
echo '#define SHAREDINDEXFILE "$(sysconfdir)/shared/index"' >>htmllibdir.h
|
|
echo '#define SQWEBPASSWD "$(pkglibexecdir)/sqwebpasswd"' >>htmllibdir.h
|
|
- if test -d $(srcdir)/../courier \
|
|
+ if true || test -d $(srcdir)/../courier \
|
|
; then \
|
|
echo '#define HOSTNAMEFILE "$(sysconfdir)/defaultdomain"' >>htmllibdir.h \
|
|
; echo '#define MAKEMIME "$(bindir)/makemime"' >>htmllibdir.h \
|
|
@@ -1188,9 +1188,6 @@ install-perms-cache:
|
|
@echo "@cachedir@ 700 @cacheowner@ bin" >>permissions.dat
|
|
|
|
cache-reminder:
|
|
- -$(mkinstalldirs) $(DESTDIR)@cachedir@
|
|
- -$(mkinstalldirs) $(DESTDIR)$(piddir)
|
|
- test -w /etc || exit 0; chown @cacheowner@ $(DESTDIR)@cachedir@
|
|
@rm -f cron.cmd
|
|
@echo '#! @SHELL@' >cron.cmd
|
|
@echo 'su -p -c "$(scriptdir)/cleancache.pl" @cacheowner@' >>cron.cmd
|