pkgsrc/lang/chicken/patches/patch-aa
obache 0c0f744d0e Update chicken to 2.60, aka 2.6.
Based on patch provided by Alaric Snell-Pym in pkgsrc-users@.

Things changed since the last release (2.5):

- Many bugfixes
- Better support for Sun's C compiler
- Input-performance has been improved
- PCRE (Perl compatible regular expressions) by Philip Hazel is now
 bundled with CHICKEN
- Static linking of extensions is now possible (when supported by
 the egg)
- The interpreter warns about references to potentially unbound variables
 in loaded code and expressions entered on the REPL
- The expansion process is traced during compilation and interpretation
 to give (slightly) more usable syntactic context in error messages
- library:
 * added `any?`, `bit-set?' and `on-exit'
- eval:
 * new procedure `set-parameterized-read-syntax!'
- posix:
 * SRFI-17 setters for `file-position`, `current-user-id',
   `current-group-id', `process-group-id'; the respective setter-procedures
   are still available but have been deprecated
 * `file-stat' returns more information (including device info)
 * added `process*'
- extras:
 * added `read-string!'
- utils:
 * `apropos' and `apropos-list' procedures
- srfi-4:
 * added `read-u8vector', `read-u8vector!' and `write-u8vector'
- srfi-18:
 * added `time->milliseconds' and `milliseconds->time'
- csi:
 * `-ss SCRIPTNAME' option
- csc:
 * accepts options given in the environment variable `CSC_OPTIONS'
 * new options `-static-extensions' and `-host'
- chicken/csc:
 * new option `-keep-shadowed-macros'
- chicken-setup:
 * accepts options given in the environment variable `CHICKEN_SETUP_OPTIONS'
 * allows retrieval and installation of eggs from subversion a repository
   and the local filesystem
 * new options `-tree FILENAME', `-svn', `-local', `-revision' and
   `-destdir PATHNAME'
 * added helper procedures `required-chicken-version' and
   `required-extension-version'
- Lots of improvements in the CMake build
2007-04-17 15:03:30 +00:00

19 lines
874 B
Text

$NetBSD: patch-aa,v 1.12 2007/04/17 15:03:30 obache Exp $
--- Makefile.am.orig 2007-02-26 07:05:57.000000000 +0000
+++ Makefile.am
@@ -298,10 +298,10 @@ pkgdata_DATA = chicken-more-macros.scm \
# Install docs and sources.
install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/doc
- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/doc/html
- -for file in $(DOCFILES); do cp $(srcdir)/$$file $(DESTDIR)$(pkgdatadir)/doc; done
- -cp $(srcdir)/html/* $(DESTDIR)$(pkgdatadir)/doc/html
+ $(mkinstalldirs) $(DESTDIR)$(prefix)/share/doc/chicken
+ $(mkinstalldirs) $(DESTDIR)$(prefix)/share/doc/chicken/html
+ -for file in $(DOCFILES); do cp $(srcdir)/$$file $(DESTDIR)$(prefix)/share/doc/chicken; done
+ -cp $(srcdir)/html/* $(DESTDIR)$(prefix)/share/doc/chicken/html
$(mkinstalldirs) $(DESTDIR)$(pkglibdir)/$(BINARY_VERSION)
# Some generated files we need to clean up.