pkgsrc/graphics/py-imaging/patches/patch-ab
drochner cd00f1eb31 update to 1.1.5
changes:
+ Runs under Python 1.5.2 and newer, including 2.4.  You may need
  additional libraries to build under 1.5.2; see instructions below.
+ New build procedure.  The setup.py file now configures and builds
  the core library as well as the bindings, in one step.
+ Added stub drivers for BUFR, FITS, GRIB, HDF5, and WMF files.
  Stub drivers can identify the file format, but relies on
  application-provided drivers to read or write images in that
  format.
+ Added experimental "LA" mode support. An "LA" image is an "L"
  image with an attached transparency layer.
+ Added "RankFilter", "MinFilter", "MedianFilter", and "MaxFilter"
  classes to the ImageFilter module.
+ Improved support for applications using multiple threads on
  systems with multiple processors and/or hyperthreading processors.
+ Added EXIF GPSInfo read support for JPEG files.
+ Lots of bug fixes and performance tweaks.

pkgsrc note: freetype and tiff support isn't built yet, should be
separate pkgs
2005-10-12 14:48:44 +00:00

44 lines
1.4 KiB
Text

$NetBSD: patch-ab,v 1.4 2005/10/12 14:48:44 drochner Exp $
--- setup.py.orig 2005-03-23 19:16:40.000000000 +0100
+++ setup.py
@@ -79,10 +79,7 @@ from distutils import sysconfig
from distutils.core import Extension, setup
from distutils.command.build_ext import build_ext
-try:
- import _tkinter
-except ImportError:
- _tkinter = None
+_tkinter = None
def add_directory(path, dir, where=None):
if dir and os.path.isdir(dir) and dir not in path:
@@ -177,9 +174,6 @@ class pil_build_ext(build_ext):
#
# add standard directories
- add_directory(library_dirs, "/usr/local/lib")
- add_directory(include_dirs, "/usr/local/include")
-
add_directory(library_dirs, "/usr/lib")
add_directory(include_dirs, "/usr/include")
@@ -210,7 +204,7 @@ class pil_build_ext(build_ext):
if find_library_file(self, "tiff"):
feature.tiff = "tiff"
- if find_library_file(self, "freetype"):
+ if 0:
# look for freetype2 include files
freetype_version = 0
for dir in include_dirs:
@@ -433,7 +427,7 @@ if __name__ == "__main__":
package_dir={"": "PIL"},
packages=[""],
platforms="Python 1.5.2 and later.",
- scripts = glob.glob("Scripts/pil*.py"),
+# scripts = glob.glob("Scripts/pil*.py"),
url=HOMEPAGE,
version=VERSION,
)