pkgsrc/comms/gkermit/Makefile
agc 9d7edcdedf The main package has changed on the distribution site by the following
change:

--- gkermit.h 1999-12-26 21:25:52.000000000 +0000
+++ gkermit.h   2003-05-27 16:30:13.000000000 +0100
@@ -233,7 +233,11 @@

 /* Externs */

+#ifdef ERRNO_H
+#include <errno.h>
+#else
 extern int errno;
+#endif /* ERRNO_H */
 #ifndef _GKERMIT_C
 extern int debug;
 #endif /* _GKERMIT_C */

but unfortunately without a corresponding version number bump. so do the
dance we usually do with unnumbered distributions, and put the distfile
locally into a (numbered) DIST_SUBDIR directory.

Bump package revision number, regen distinfo file, and one cosmetic
change to make the WRKSRC definition appear in a more suitable place in
the package Makefile.
2003-06-17 14:16:33 +00:00

28 lines
769 B
Makefile

# $NetBSD: Makefile,v 1.10 2003/06/17 14:16:33 agc Exp $
#
DISTNAME= gkermit
PKGNAME= gkermit-1.00
PKGREVISION= 1
CATEGORIES= comms
MASTER_SITES= ftp://kermit.columbia.edu/kermit/archives/
MAINTAINER= fredb@netbsd.org
HOMEPAGE= http://www.columbia.edu/kermit/gkermit.html
COMMENT= minimal implementation of the ``kermit'' protocol (GPL'd)
WRKSRC= ${WRKDIR}
DIST_SUBDIR= gkermit-1.00
USE_BUILDLINK2= # defined
ALL_TARGET= posix
MAKEFILE= makefile
MAKE_ENV+= KFLAGS="${CFLAGS}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gkermit ${PREFIX}/bin/gkermit; \
${INSTALL_MAN} ${WRKSRC}/gkermit.nr ${PREFIX}/man/man1/gkermit.1; \
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/gkermit
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gkermit
.include "../../mk/bsd.pkg.mk"