pkgsrc/net/jftpgw/patches/patch-aa
martti 5d3b535ea7 changes new in 0.13.5, Wed Jun 3 16:17:44 CEST 2004
* Fixed a bug regarding changing uids/gids (Niki Waibel)
  * Fixed a bug regarding changeroot (Niki Waibel)
  * Clarified the setting of the umask of the logfile (Niki Waibel)
  * Fixed a bug in the commonlog logging format (Andrew Zhoglo)
  * Passing complete encrypted password to crypt, not only salt (Arkadius
    Nowakowski)
  * Allowing STOU command (Pawel Worach)
  * Allowing more errors at the call to accept() that are connection related
    and don't force us to shut down the server (Reil Brennan)
  * Added option to close the connection after consequent protocol violations
  * Fixed compiler warnings with gcc 3 (includes renaming of log() to jlog())
  * Updated configure.in to new autoconf/automake versions
  * "Entering Passive Mode" did not get logged because of "PASS" substring
    (Yan, Dong)
  * Changed xferlog-style (Toni)
  * jftpgw didn't compile on NetBSD 2.0E because IPL_NAT is not known there
    anymore - added #ifdef (Ray Phillips)
  * annotated default configuration file
2006-04-10 09:31:01 +00:00

21 lines
1.3 KiB
Text

$NetBSD: patch-aa,v 1.2 2006/04/10 09:31:01 martti Exp $
--- Makefile.in.orig 2004-06-04 13:29:12.000000000 +0300
+++ Makefile.in 2006-04-10 12:15:38.000000000 +0300
@@ -533,11 +533,12 @@
# use mkinstalldirs, not "install -d"
# don't install a list of file. Just one file per install.
# if you have more of them, create a subdirectory with an extra Makefile
+examplesdir=$(datadir)/examples/jftpgw
+
install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(sysconfdir)
- if test -f $(DESTDIR)$(sysconfdir)/jftpgw.conf; then echo -e "\n\nMoving $(DESTDIR)$(sysconfdir)/jftpgw.conf to $(DESTDIR)$(sysconfdir)/jftpgw.conf.old\n\n"; mv $(DESTDIR)$(sysconfdir)/jftpgw.conf $(DESTDIR)$(sysconfdir)/jftpgw.conf.old; fi
- $(INSTALL_DATA) jftpgw.conf.sample $(DESTDIR)$(sysconfdir)/jftpgw.conf
- $(INSTALL_DATA) jftpgw.conf.sample $(DESTDIR)$(sysconfdir)/jftpgw.conf.sample
+ $(mkinstalldirs) $(DESTDIR)$(examplesdir)
+ if test -f $(DESTDIR)$(sysconfdir)/jftpgw.conf; then echo -e "\n\nMoving $(DESTDIR)$(examplesdir)/jftpgw.conf to $(DESTDIR)$(examplesdir)/jftpgw.conf.old\n\n"; mv $(DESTDIR)$(examplesdir)/jftpgw.conf $(DESTDIR)$(examplesdir)/jftpgw.conf.old; fi
+ $(INSTALL_DATA) jftpgw.conf.sample $(DESTDIR)$(examplesdir)/jftpgw.conf
# remove ALL you have installed in install-data-local or install-exec-local
uninstall-local: