pkgsrc/net/libsoup/patches/patch-tests_Makefile.in
leot fc6b0ca336 libsoup: Update net/libsoup to 2.64.2
pkgsrc changes:
 - Add a dependency to www/libpsl
 - Add a patch to adjust running of the tests (otherwise because
   `APACHE_HTTPD' is defined to `no' a `no' program will be executed but
   will fail because no `no' program is usually available)

Changes:
Changes in libsoup from 2.64.1 to 2.64.2:

 * TLD tests updated (Claudio Saavedra)
 * Updated translations: Serbian

Changes in libsoup from 2.63.92 to 2.64.1:

 * Many fixes to the meson build system (which, by the way, is
   NOT official yet) (#13, Tomas Popela)
 * Updated translations: Belarusian.

Changes in libsoup from 2.63.92 to 2.64.0:

 * Many fixes to the meson build system [#7, #8, #9, #11, Tomas Popela]
 * Updated translations: Brazilian Portuguese, Galician,
          Hungarian, Latvian, Danish.

Changes in libsoup from 2.63.91 to 2.63.92:

 * Make sure that XMLRPC tests build in Debian too [Claudio Saavedra]
 * Distribute missing meson files [Claudio Saavedra]
 * Some fixes to the meson build files [Claudio Saavedra]
 * Updated Korean and Swedish translations

Changes in libsoup from 2.63.90 to 2.63.91:

 * Simplify soup_hosts_matches_host() [Claudio Saavedra]
 * Add new tests for trailing dots in domain names [Claudio Saavedra]
 * Updated Turkish translation

Changes in libsoup from 2.63.2 to 2.63.90:

 * Set default cookie path for NULL origins [#1, Adrian Perez de Castro]
 * Fixes to GObject-introspection [bgo#794787, Corentin Noël]
 * Use atomic-refcounting in classes that are not using GObject-refcounting
   [bgo#785110, Edward Hervey]
 * Many Coverity-found code fixes [bgo#781771, Milan Crha]
 * Bail out on cookie-jar calls with empty hostnames [#3, Michael Catanzaro]
 * Fixes to the simple-httpd example [#2, Mooffie]
 * Updated translations: Chinese (Taiwan), Catalan

 Note: from now onwards bgo# references bugs in GNOME Bugzilla
 and # issues in GNOME gitlab.

Changes in libsoup from 2.63.1 to 2.63.2:

 * Many fixes to the meson build system support [#795324,
          #782410, Tomas Popela, Jan Alexander Steffens]
 * Fixes to xmlrpc-server test with PHP >= 7.2 and related
   [#795111, #782410 Jan Alexander Steffens]
 * Fix critical warning in SoupSocket [Carlos Garcia Campos]
 * Updated translations: Romanian, Friulian, Slovenian,
   Czech, Spanish, Indonesian, Chinese (China).
2018-10-23 07:17:53 +00:00

25 lines
921 B
Text

$NetBSD: patch-tests_Makefile.in,v 1.1 2018/10/23 07:17:53 leot Exp $
Run APACHE_HTTPD targets only if an APACHE_HTTPD was defined
(otherwise this lead to executing a `no' program and to fail the
tests due that).
--- tests/Makefile.in.orig 2018-10-22 16:12:48.000000000 +0000
+++ tests/Makefile.in
@@ -2181,12 +2181,12 @@ uninstall-am: uninstall-installed_testLT
soup-tests.gresource: soup-tests.gresource.xml $(RESOURCES)
$(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) $<
-check: start-httpd
+@HAVE_APACHE_TRUE@check: start-httpd
-check-local: check-TESTS
- @$(MAKE) kill-httpd
+@HAVE_APACHE_TRUE@check-local: check-TESTS
+@HAVE_APACHE_TRUE@ @$(MAKE) kill-httpd
-.PHONY: start-httpd kill-httpd
+@HAVE_APACHE_TRUE@.PHONY: start-httpd kill-httpd
start-httpd:
@$(APACHE_HTTPD) -d $(abs_srcdir) -c "DefaultRuntimeDir `pwd`" -c "PidFile `pwd`/httpd.pid" -f `pwd`/httpd.conf -k start;