pkgsrc/multimedia/dvdstyler/patches/patch-aa
wiz 051c4e03e5 Update to 1.5.1:
Version 1.5.1 <2007.07.07>
--------------------------

  * added burning under Windows
  * added support of dvdisaster (thanks to Torsten Rupp)
  * added Czech translation (thanks to Vlastimil Skacel)
  * added Dutch translation (thanks to Patrick Vijgeboom)
  * added Swedish translation (thanks to Daniel Nylander)

Version 1.5 final <2007.05.16>
------------------------------

  * new stable release
  * fixed some bugs

Version 1.5 beta 7 <2006.11.10>
-------------------------------

  * added selection of video and audio format for DVD
  * fixed spumux error

Version 1.5 beta 6 <2006.10.12>
-------------------------------

  * new logo (thanks to Alejandro Slocker Escarpa)
  * added play all flag to button action
  * added displaying of safe tv area
  * added displaying of grid
  * now buttons are always over objects
  * fixed error when generating dvd with text based buttons
  * added new button based upon a picture by Benji Park (thanks to Fgoset)

Version 1.5 beta 5 <2006.03.15>
-------------------------------

  * added possibility to arrange menu objects/buttons
  * added possibility to specify volume name
  * added two new buttons
  * fixed some bugs
2007-10-25 00:02:02 +00:00

68 lines
2.2 KiB
Text

$NetBSD: patch-aa,v 1.3 2007/10/25 00:02:02 wiz Exp $
--- configure.in.orig 2007-02-22 18:34:46.000000000 +0000
+++ configure.in
@@ -57,24 +57,52 @@ if $WX_CONFIG_NAME --cxxflags | grep -q
AM_CONDITIONAL(USE_KDE, test 0 = 1)
AM_CONDITIONAL(USE_GNOME, test 0 = 1)
else
+ AC_ARG_ENABLE([kde],
+ AS_HELP_STRING([--enable-kde],
+ [enable kde support (default: yes)]),
+ ac_cv_enable_kde="$enableval", ac_cv_enable_kde="yes")
+ if test x"$ac_cv_enable_kde" = x"yes" ; then
FIND_KDE
+ else
+ AC_MSG_WARN([*** kde support disabled ***])
+ USE_KDE_FALSE="yes"
+ fi
+ AC_ARG_ENABLE([gnome],
+ AS_HELP_STRING([--enable-gnome],
+ [enable gnome support (default: yes)]),
+ ac_cv_enable_gnome="$enableval", ac_cv_enable_gnome="yes")
+ if test x"$ac_cv_enable_gnome" = x"yes" ; then
FIND_GNOME
+ else
+ AC_MSG_WARN([*** gnome support disabled ***])
+ USE_GNOME_FALSE="yes"
+ fi
fi
CXXFLAGS="$CXXFLAGS $DEBUG_FLAGS $WX_CXXFLAGS "
LIBS="$LIBS $WX_LIBS "
+AC_SUBST([USE_KDE_FALSE])
+AC_SUBST([USE_GNOME_FALSE])
dnl check for wxSVG
AC_CHECK_LIB(wxsvg, main, [LIBS="$LIBS -lwxsvg"], [AC_MSG_ERROR([*** missing wxSVG library (wxsvg.sf.net) ***])])
AC_CHECK_HEADER([wxSVG/svg.h], [], [AC_MSG_ERROR([*** missing wxSVG library (wxsvg.sf.net) ***])])
-dnl check gnomeui-2.0
CHECK_WX_BUILT_WITH_GTK2()
-if test x"$GTK_USEDVERSION" = x"2" ; then
- PKG_CHECK_MODULES(GNOMEUI2, libgnomeui-2.0, GNOME2="-DGNOME2",
+
+dnl check for libgnomeui>=2.0
+AC_ARG_ENABLE([libgnomeui],
+ AS_HELP_STRING([--enable-libgnomeui],
+ [enable libgnomeui to render thumbnails (default: yes)]),
+ ac_cv_enable_libgnomeui="$enableval", ac_cv_enable_libgnomeui="yes")
+
+if test x"$ac_cv_enable_libgnomeui" = x"yes" ; then
+ PKG_CHECK_MODULES(GNOMEUI2, libgnomeui-2.0, GNOME2="-DGNOME2",
AC_MSG_WARN([libgnomeui will not be used for rendering of thumbnails]))
+ CXXFLAGS="$CXXFLAGS $GNOME2"
+ LIBS="$LIBS $GNOMEUI2_LIBS "
+else
+ AC_MSG_WARN([libgnomeui dependency disabled])
fi
-CXXFLAGS="$CXXFLAGS $GNOME2"
-LIBS="$LIBS $GNOMEUI2_LIBS "
CXXFLAGS="$CXXFLAGS -DDATADIR=\\\"$datadir/$PACKAGE\\\""
@@ -148,5 +176,4 @@ AC_OUTPUT([
buttons/Makefile
objects/Makefile
data/Makefile
- install.win32/Makefile
])