Move config files to standard location. Make Apache/Nginx compatible (based on mail/rouncube). Upstream changes follow. 3.7.1 * Fix for auth bypass when using the authentication module * Fix for a XSS in the view adding interface * Update JQuery Mobile library to 1.4.5 3.7.0 * Cubism integration * Ganglia Reporting * Couple reported XSS issues have been corrected 3.6.2 * Performance improvements * New clearer heatmaps * Other minor improvements and fixes 3.5.7 * Required Jquery files were missing from 3.5.6 release. 3.5.6 * Number of fixes to address XSS (Cross Site Scripting) issues * Enhancement to the host view if use option "metric_groups_initially_collapsed". Clicking on metric groups dynamically loads images instead of reloading the page * Fixed mobile view * Incorporate legend in the selection when doing Inspect graph * Stacked graph fixes * Numerous other fixes and enhancements 3.5.2 * Fix for stacked graphs not showing after upgrading to 3.5.1 * Inspect graph now uses AJAX calls to retrieve data which should help in situations where users use Basic authentication 3.5.1 * Security advisory * Support for same hostname being in multiple clusters 3.5.0 * Enable zoom to a selection in Inspect Graph * Add Jump to Metric group drop down * Add Timeshift functionality to graphs * Other misc fixes and improvements 3.4.2 * Improvements to the live dashboard * Fixed the aggregate graphs metric auto complete which broke in 3.4.1 * Add ability to specify critical and warning thresholds. Use in Live Dashboard and Views. * Minor bug fixes 3.4.1 * Major improvements to Inspect Graph thanks to Peter Piela - deselect all data sources, select individual sources, change graph type from stack to line and vice versa * Live Dashboard - integration of Tasseo * Metrics drop down now includes ability to select optional reports No changelog could be found for 3.1.3-3.4.0.
28 lines
1.4 KiB
Text
28 lines
1.4 KiB
Text
$NetBSD: patch-Makefile,v 1.1 2016/02/16 13:05:23 fhajny Exp $
|
|
|
|
Assert proper paths.
|
|
|
|
--- Makefile.orig 2015-10-01 15:47:41.000000000 +0000
|
|
+++ Makefile
|
|
@@ -33,7 +33,7 @@ clean:
|
|
rm -rf $(TARGETS) $(DIST_DIR) $(DIST_TARBALL) rpmbuild
|
|
|
|
conf_default.php: conf_default.php.in
|
|
- sed -e "s|@vargmetadir@|$(GMETAD_ROOTDIR)|" -e "s|@vargwebstatedir@|$(GWEB_STATEDIR)|g" conf_default.php.in > conf_default.php
|
|
+ sed -e "s|@etcdir@|$(GCONFDIR)|" -e "s|@vargmetadir@|$(GMETAD_ROOTDIR)|" -e "s|@vargwebstatedir@|$(GWEB_STATEDIR)|g" conf_default.php.in > conf_default.php
|
|
|
|
ganglia-web.spec: ganglia-web.spec.in
|
|
sed -e s/@GWEB_VERSION@/$(GWEB_VERSION)/ -e "s|@vargwebdir@|$(GWEB_STATEDIR)|" -e "s|@varapacheuser@|$(APACHE_USER)|g" -e "s|@etcdir@|$(GCONFDIR)|g" ganglia-web.spec.in > ganglia-web.spec
|
|
@@ -51,10 +51,9 @@ install: dist-dir
|
|
mkdir -p $(DESTDIR)/$(GWEB_STATEDIR)/dwoo/compiled && \
|
|
mkdir -p $(DESTDIR)/$(GWEB_STATEDIR)/dwoo/cache && \
|
|
mkdir -p $(DESTDIR)/$(GWEB_STATEDIR) && \
|
|
- rsync -a $(DIST_DIR)/conf $(DESTDIR)/$(GWEB_STATEDIR) && \
|
|
+ rsync -a $(DIST_DIR)/conf $(DESTDIR)/$(GCONFDIR) && \
|
|
mkdir -p $(DESTDIR)/$(GDESTDIR) && \
|
|
- rsync --exclude "conf" -a $(DIST_DIR)/* $(DESTDIR)/$(GDESTDIR) && \
|
|
- chown -R $(APACHE_USER):$(APACHE_USER) $(DESTDIR)/$(GWEB_STATEDIR)
|
|
+ rsync --exclude "conf" -a $(DIST_DIR)/* $(DESTDIR)/$(GDESTDIR)
|
|
|
|
dist-gzip: dist-dir
|
|
if [ -f $(DIST_TARBALL) ]; then \
|