pkgsrc/www/ap2-xslt2/patches/patch-ae
xtraeme aca495c729 Initial import of ap2-xslt2 (known as mod-xslt2).
mod-xslt2 is a server side module able to transform ``xml''
documents in ``html'' (or to any other format) before they
even get back to the browser.

mod-xslt2 main features include:

* Ability to parse generated xml (ability to parse the output of
  php or perl scripts).

* Ability to use the ``xslt'' indicated by the <?xml-stylesheet
  processing instruction.

* Ability to send back the xml file unparsed to the browser.

* Ability to fetch xslt or DTDs from scripts rather than from
  static files.

* Ability to fetch a different xslt depending on the content of
  the request headers, of the get parameters or the web server
  environment.

* Ability to allow xslt stylesheets to make use of these
  variables to generate output.

--
http://www.mod-xslt2.com/
2006-12-07 02:34:01 +00:00

17 lines
766 B
Text

$NetBSD: patch-ae,v 1.1.1.1 2006/12/07 02:34:01 xtraeme Exp $
--- doc/man/Makefile.in.orig 2004-10-02 10:24:10.000000000 +0200
+++ doc/man/Makefile.in 2006-12-07 03:17:46.000000000 +0100
@@ -77,8 +77,10 @@
$(XSLT) $(XSLTPARAM) modxslt-parse.xml
install: modxslt-config.1 modxslt-perror.1 modxslt-parse.1
- $(INSTALL) -d $(DESTDIR)$(mandir)/man1
- $(INSTALL) --mode=0644 --owner=root --group=root $^ $(DESTDIR)$(mandir)/man1
+ $(BSD_INSTALL_MAN_DIR) $(DESTDIR)$(mandir)/man1
+ $(BSD_INSTALL_MAN) modxslt-config.1 $(DESTDIR)$(mandir)/man1
+ $(BSD_INSTALL_MAN) modxslt-perror.1 $(DESTDIR)$(mandir)/man1
+ $(BSD_INSTALL_MAN) modxslt-parse.1 $(DESTDIR)$(mandir)/man1
uninstall:
rm $(DESTDIR)$(mandir)/man1/{modxslt-config.1,modxslt-parse.1,modxslt-perror.1}