b2f5605b10
Package changes: Use PKG_OPTIONS_GROUP framework Add package option 'python' to support the new python scripts flow-rpt2rrd, flow-log2rrd and flow-rptfmt. Changes since last packaged version (0.67): * 5-11-2005 flow-tools 0.68 released. * added flow-rpt2rrd - post process flow-report into RRD's. * added flow-log2rrd - post process logs from * added flow-rptfmt - post process flow-report into readable and HTML. * ftstat.c s/psizr256/psize256/ - uebelacker@tuhh.de * rec_v5->engine_id not set properly in ftdecode.c - baldwinL@mynetwatchman.com * --enable-lfs set flags for large file support - alexbrennen@gmail.com * Added CryptoPAn support to flow-xlate req by Abilene * mailing list archive is available at mail-archive.com req by spork@bway.net * flow-cat.c: progress debug output - weinhold@berbee.com * portability: gcc no longer supports goto label which label is at the end of a compound statement - Andreas Jochens <aj@andaco.de> * flow-stat.c: protect from divize by zero - should only happen on invalid flows - - Espen.Breivik@uninett.no * flow-filter.c: exaddr filter - Espen.Breivik@uninett.no * ftxlate.c: tag-mask eval_tag_mask() not using correct offsets - Cougar <cougar@random.ee> & kgraham@valueclick.com * flow-send: default tx_delay to 0 like flow-fanout - rjd@merit.edu * flow-export: debug should be global - dwatanab@uci.edu * flow-report: path will accept spaces, ie |flow-rpt2rrd -p rrd -k 25 * flow-report: records is in rec1 * flow-fanout: did not set address family for receive fd - noted by fingers@fingers.co.za * docs: add FILES section to man pages * flow-report: -hh to list available reports * flow-report, flow-tag, flow-xlate, flow-nfilter. Run-time variable expansion of the form @VAR or @{VAR:default} for config files. * flow-receive: dropped inline tagging and nfilter support
108 lines
4 KiB
Text
108 lines
4 KiB
Text
$NetBSD: patch-af,v 1.4 2005/06/23 14:20:56 seb Exp $
|
|
|
|
--- lib/Makefile.in.orig 2005-06-21 23:24:04.000000000 +0000
|
|
+++ lib/Makefile.in
|
|
@@ -95,7 +95,7 @@ AM_CFLAGS = -g -Wall
|
|
|
|
DEFS = -I. -I$(srcdir)/lib
|
|
|
|
-include_HEADERS = ftlib.h ftqueue.h radix.h ftpaths.h ftconfig.h
|
|
+pkginclude_HEADERS = ftlib.h ftqueue.h radix.h ftpaths.h ftconfig.h
|
|
lib_LIBRARIES = libft.a
|
|
|
|
libft_a_SOURCES = ftio.c ftswap.c ftencode.c ftdecode.c ftprof.c bit1024.c \
|
|
@@ -148,10 +148,10 @@ CCLD = $(CC)
|
|
LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
|
|
CFLAGS = @CFLAGS@
|
|
DIST_SOURCES = $(libft_a_SOURCES)
|
|
-HEADERS = $(include_HEADERS)
|
|
+HEADERS = $(pkginclude_HEADERS)
|
|
|
|
-DIST_COMMON = $(include_HEADERS) Makefile.am Makefile.in ftconfig.h.in \
|
|
- ftpaths.h.in strerror.c strsep.c strtoull.c
|
|
+DIST_COMMON = $(pkginclude_HEADERS) Makefile.am Makefile.in \
|
|
+ ftconfig.h.in ftpaths.h.in strerror.c strsep.c strtoull.c
|
|
SOURCES = $(libft_a_SOURCES)
|
|
|
|
all: ftconfig.h
|
|
@@ -270,23 +270,23 @@ distclean-depend:
|
|
$(COMPILE) -c `cygpath -w $<`
|
|
CCDEPMODE = @CCDEPMODE@
|
|
uninstall-info-am:
|
|
-includeHEADERS_INSTALL = $(INSTALL_HEADER)
|
|
-install-includeHEADERS: $(include_HEADERS)
|
|
+pkgincludeHEADERS_INSTALL = $(INSTALL_HEADER)
|
|
+install-pkgincludeHEADERS: $(pkginclude_HEADERS)
|
|
@$(NORMAL_INSTALL)
|
|
- $(mkinstalldirs) $(DESTDIR)$(includedir)
|
|
- @list='$(include_HEADERS)'; for p in $$list; do \
|
|
+ $(mkinstalldirs) $(DESTDIR)$(pkgincludedir)
|
|
+ @list='$(pkginclude_HEADERS)'; for p in $$list; do \
|
|
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
|
- echo " $(includeHEADERS_INSTALL) $$d$$p $(DESTDIR)$(includedir)/$$f"; \
|
|
- $(includeHEADERS_INSTALL) $$d$$p $(DESTDIR)$(includedir)/$$f; \
|
|
+ echo " $(pkgincludeHEADERS_INSTALL) $$d$$p $(DESTDIR)$(pkgincludedir)/$$f"; \
|
|
+ $(pkgincludeHEADERS_INSTALL) $$d$$p $(DESTDIR)$(pkgincludedir)/$$f; \
|
|
done
|
|
|
|
-uninstall-includeHEADERS:
|
|
+uninstall-pkgincludeHEADERS:
|
|
@$(NORMAL_UNINSTALL)
|
|
- @list='$(include_HEADERS)'; for p in $$list; do \
|
|
+ @list='$(pkginclude_HEADERS)'; for p in $$list; do \
|
|
f="`echo $$p | sed -e 's|^.*/||'`"; \
|
|
- echo " rm -f $(DESTDIR)$(includedir)/$$f"; \
|
|
- rm -f $(DESTDIR)$(includedir)/$$f; \
|
|
+ echo " rm -f $(DESTDIR)$(pkgincludedir)/$$f"; \
|
|
+ rm -f $(DESTDIR)$(pkgincludedir)/$$f; \
|
|
done
|
|
|
|
ETAGS = etags
|
|
@@ -355,7 +355,7 @@ check: check-am
|
|
all-am: Makefile $(LIBRARIES) $(HEADERS) ftconfig.h
|
|
|
|
installdirs:
|
|
- $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
|
|
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(pkgincludedir)
|
|
|
|
install: install-am
|
|
install-exec: install-exec-am
|
|
@@ -398,7 +398,7 @@ info: info-am
|
|
|
|
info-am:
|
|
|
|
-install-data-am: install-includeHEADERS
|
|
+install-data-am: install-pkgincludeHEADERS
|
|
|
|
install-exec-am: install-libLIBRARIES
|
|
|
|
@@ -416,21 +416,21 @@ mostlyclean: mostlyclean-am
|
|
|
|
mostlyclean-am: mostlyclean-compile mostlyclean-generic
|
|
|
|
-uninstall-am: uninstall-includeHEADERS uninstall-info-am \
|
|
- uninstall-libLIBRARIES
|
|
+uninstall-am: uninstall-info-am uninstall-libLIBRARIES \
|
|
+ uninstall-pkgincludeHEADERS
|
|
|
|
.PHONY: GTAGS all all-am check check-am clean clean-generic \
|
|
clean-libLIBRARIES distclean distclean-compile distclean-depend \
|
|
distclean-generic distclean-hdr distclean-tags distdir dvi \
|
|
dvi-am info info-am install install-am install-data \
|
|
- install-data-am install-exec install-exec-am \
|
|
- install-includeHEADERS install-info install-info-am \
|
|
- install-libLIBRARIES install-man install-strip installcheck \
|
|
+ install-data-am install-exec install-exec-am install-info \
|
|
+ install-info-am install-libLIBRARIES install-man \
|
|
+ install-pkgincludeHEADERS install-strip installcheck \
|
|
installcheck-am installdirs maintainer-clean \
|
|
maintainer-clean-generic mostlyclean mostlyclean-compile \
|
|
mostlyclean-generic tags uninstall uninstall-am \
|
|
- uninstall-includeHEADERS uninstall-info-am \
|
|
- uninstall-libLIBRARIES
|
|
+ uninstall-info-am uninstall-libLIBRARIES \
|
|
+ uninstall-pkgincludeHEADERS
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|