pkgsrc/wm/ion/patches/patch-ad
cube f3a40fbb6d Update to ion-20040207 (a.k.a ion2). This is the new stable version of
Ion, two years after the last one!

It is actually an update of ion-devel, which will then disappear before
a new development branch is created for Ion.

Most notable changes (since import of ion-devel, see ChangeLog in the
distribution for a full listing):
	* Integration of the dock module
	* Workspace query asks for type of workspace when creating new.
	* Previous frame geometry (for maximize and shade) is saved in the
	  workspaces save file.
	* Support changes in X keyboard map.
	* Autoconf script
	* The dock no longer gets focused when the pointer enters it.
	* Fill _NET_SUPPORTED root window property with the supported
	  features (_NET_WM_FULLSCREEN, _NET_WM_NAME, _NET_VIRTUAL_ROOTS).
	* Transient size calculation fixed.
	* Creating frame for a transient on a floatws will raise the frame
	  containing the transient_for window.
	* Minor memory leak removed: drawing engine colour group name.
2004-02-23 13:40:21 +00:00

18 lines
552 B
Text

$NetBSD: patch-ad,v 1.3 2004/02/23 13:40:21 cube Exp $
--- etc/Makefile.orig 2004-02-07 16:37:01.000000000 +0100
+++ etc/Makefile
@@ -21,9 +21,9 @@ include $(TOPDIR)/rules.mk
######################################
_install:
- $(INSTALLDIR) $(ETCDIR)
+ $(INSTALLDIR) $(EXDIR)
for i in $(ETC); do \
- $(INSTALL) -m $(DATA_MODE) $$i $(ETCDIR); \
+ $(INSTALL) -m $(DATA_MODE) $$i $(EXDIR); \
done
- rm -f $(ETCDIR)/draw.lua
- ln -s look-cleanviolet.lua $(ETCDIR)/draw.lua
+ rm -f $(EXDIR)/draw.lua
+ ln -s look-cleanviolet.lua $(EXDIR)/draw.lua