pkgsrc/wm/ion/patches/patch-ah
cube 2ac989f37f Update to version 20040407. Enable pkgviews installation and make good use
of PKG_SYSCONFDIR.  Thanks to Amitai Schlair.

Changes:
  * Added a kludge to deal with waitrelease when modifiers have
    already been released.
  * Fixed assert-crash when attempting to split a frame not managed
    by a WIonWS.
  * Don't put input method failure complaints in startup error log.
  * Client window unmap handling fixes (?).
  * Made drawing engine objects inheritable and initialisation code
    reusable.
  * Improvements and fixes in keyboard mapping changes handling.
  * Slightly reduce flicker with apps that update title too often by
    removing a redundant change notify call.
  * Added a check in layout loading code to detect corrupt files with
    multiple instances of the same client window.
  * Updated Mozilla Firebird entries in menu configuration files to
    Mozilla Firefox.
  * Added important missing function WFloatWS.attach.
  * Take gravity better into account when reparenting windows on
    exit.
  * Made some goto_* routines return the region that will be focused
    and added asynchronity notices in documentation.
  * Some tab drag&drop fixes.
  * Startup errorlog display fixed when we didn't even open the
    display.
  * WIonWS load routines better handle corrupt sizes in layout
    savefile.
  * Object/proxy cache references to proxies weren't being cleared
    when objects were destroyed.
  * Added exported function to get line editor 'mark'.
  * Man pages fixes
  * Fixed toggle_tab on floatframes.
  * Move/resize display was never showing position.
  * Completions display wasn't being refreshed, if its size wasn't
    changed between completions.
  * Oops, warping on workspace switch had been broken at some point.
  * Some autoconf script portability and other fixes.
  * The function floatws_current was not being exported as
    WFloatWS.current.
  * Client window focusing routine was not setting "awaiting focus"
    status.
  * Removed superfluous debugging message.
  * querylib.query_renameworkspace documentation was out-of-date.
  * Mod1+Enter full screen toggle was not mentioned on the manual
    page.
2004-05-06 04:38:45 +00:00

26 lines
796 B
Text

$NetBSD: patch-ah,v 1.2 2004/05/06 04:38:45 cube Exp $
--- system-ac.mk.in.orig 2004-04-02 03:17:08.000000000 -0500
+++ system-ac.mk.in
@@ -16,11 +16,11 @@ exec_prefix=@exec_prefix@
# Main binaries
BINDIR=@bindir@
# Configuration .lua files
-ETCDIR=@sysconfdir@/@PACKAGE_TARNAME@
+ETCDIR=@sysconfdir@
# Some .lua files and ion-* shell scripts
SHAREDIR=@datadir@/@PACKAGE_TARNAME@
# Manual pages
-MANDIR=@datadir@/man
+MANDIR=@prefix@/man
# Some documents
DOCDIR=@datadir@/doc/@PACKAGE_TARNAME@
# Nothing at the moment
@@ -33,6 +33,7 @@ MODULEDIR=@libdir@/@PACKAGE_TARNAME@
LCDIR=@libdir@/@PACKAGE_TARNAME@/lc
# ion-completefile (does not belong in SHAREDIR being a binary file)
EXTRABINDIR=@libexecdir@/@PACKAGE_TARNAME@
+EXDIR=@datadir@/examples/@PACKAGE_TARNAME@
##
## Modules