9b049008ea
changes: support for newer versions of palmos (>3.5) support for arm newer versions of toolchain
32 lines
1.4 KiB
Text
32 lines
1.4 KiB
Text
$NetBSD: patch-al,v 1.1 2002/10/15 23:07:17 dillo Exp $
|
|
|
|
--- gcc/gcc/Makefile.in.orig Thu Jan 25 15:02:58 2001
|
|
+++ gcc/gcc/Makefile.in
|
|
@@ -2434,7 +2438,7 @@ install: $(INSTALL_TARGET) ; @true
|
|
# Install the driver last so that the window when things are
|
|
# broken is small.
|
|
install-normal: install-common $(INSTALL_HEADERS) $(INSTALL_LIBGCC) \
|
|
- $(INSTALL_CPP) install-man install-info intl.install lang.install-normal \
|
|
+ $(INSTALL_CPP) install-man intl.install lang.install-normal \
|
|
install-driver
|
|
|
|
# Do nothing while making gcc with a cross-compiler. The person who
|
|
@@ -2590,7 +2605,7 @@ install-info: doc installdirs lang.insta
|
|
-chmod a-x $(infodir)/cpp.info* $(infodir)/gcc.info*
|
|
|
|
# Install the man pages.
|
|
-install-man: installdirs $(srcdir)/gcc.1 $(srcdir)/cccp.1 lang.install-man
|
|
+install-man: installdirs $(srcdir)/gcc.1 lang.install-man
|
|
-if [ -f gcc-cross$(exeext) ] ; then \
|
|
rm -f $(man1dir)/$(GCC_CROSS_NAME)$(manext); \
|
|
$(INSTALL_DATA) $(srcdir)/gcc.1 $(man1dir)/$(GCC_CROSS_NAME)$(manext); \
|
|
@@ -2600,9 +2615,6 @@ install-man: installdirs $(srcdir)/gcc.1
|
|
$(INSTALL_DATA) $(srcdir)/gcc.1 $(man1dir)/$(GCC_INSTALL_NAME)$(manext); \
|
|
chmod a-x $(man1dir)/$(GCC_INSTALL_NAME)$(manext); \
|
|
fi
|
|
- -rm -f $(man1dir)/cccp$(manext)
|
|
- -$(INSTALL_DATA) $(srcdir)/cccp.1 $(man1dir)/cccp$(manext)
|
|
- -chmod a-x $(man1dir)/cccp$(manext)
|
|
|
|
# Install the library.
|
|
install-libgcc: libgcc.a installdirs
|