ac268c80a6
* New Version Numbering System * Minimal squid.conf improvements * Native IPv6 Support * Error Page Localization * Connection Pinning (for NTLM Auth Passthrough) * Quality of Service (QoS) Flow support * SSL Bump (for HTTPS Filtering and Adaptation) * eCAP Adaptation Module support This package is heavily based on work by Michael van Elst which includes fixes for the IPv6 support.
40 lines
1.2 KiB
Text
40 lines
1.2 KiB
Text
$NetBSD: patch-ab,v 1.1.1.1 2009/04/20 21:27:40 tron Exp $
|
|
|
|
--- configure.in.orig 2009-04-08 12:51:47.000000000 +0200
|
|
+++ configure.in
|
|
@@ -2231,6 +2231,7 @@ AC_CHECK_HEADERS( \
|
|
libc.h \
|
|
libgen.h \
|
|
limits.h \
|
|
+ machine/byte_swap.h \
|
|
malloc.h \
|
|
math.h \
|
|
memory.h \
|
|
@@ -2320,6 +2321,7 @@ AC_CHECK_HEADERS( \
|
|
netinet/ip_icmp.h \
|
|
netinet/ip_nat.h\
|
|
netinet/ipl.h \
|
|
+ net/pf/pfvar.h \
|
|
net/pfvar.h \
|
|
sys/mount.h\
|
|
resolv.h \
|
|
@@ -2770,8 +2772,8 @@ if test "$GCC" = "yes"; then
|
|
GCCVER=`$CC -v 2>&1 | awk '$2 == "version" {print $3}'`
|
|
case "$GCCVER" in
|
|
[2.95.[123]])
|
|
- AC_MSG_NOTICE([Removing -O for gcc on $host with GCC $GCCVER])
|
|
- CFLAGS="`echo $CFLAGS | sed -e 's/-O[[0-9]]*//'`"
|
|
+ echo "Making -O\[[2-9\]] to -O for gcc on $host with GCC $GCCVER"
|
|
+ CFLAGS="`echo $CFLAGS | sed -e 's/-O[[0-9]]*/-O/'`"
|
|
;;
|
|
esac
|
|
fi
|
|
@@ -3131,7 +3133,7 @@ dnl PF support requires a header file.
|
|
if test "$PF_TRANSPARENT" ; then
|
|
AC_MSG_CHECKING(if PF header file is installed)
|
|
# hold on to your hats...
|
|
- if test "$ac_cv_header_net_pfvar_h" = "yes"; then
|
|
+ if test "$ac_cv_header_net_pfvar_h" = "yes" || test "$ac_cv_header_net_pf_pfvar_h" = "yes"; then
|
|
PF_TRANSPARENT="yes"
|
|
AC_DEFINE(PF_TRANSPARENT, 1)
|
|
else
|