9257c54713
2014-06-16: 0.7.0 "Kryoptonite" - Partial IPv6 support (#107) Client can connect to iodined through an relaying IPv6 nameserver. Server only supports IPv4 for now. Traffic inside tunnel is IPv4. - Add socket activation for systemd, by Michael Scherer. - Add automated lookup of external ip (via -n auto). - Bugfix for OS X (Can't assign requested address) - Fix DNS tunneling bug caused by uninitialized variable, #94 - Handle spaces when entering password interactively, fixes #93. Patch by Hagar. - Add -R option to set OpenBSD routing domain for the DNS socket. Patch by laurent at gouloum fr, fixes #95. - Add android patches and makefile, from Marcel Bokhorst, fixes #105. - Added missing break in iodine.c, by Pavel Pergamenshchik, #108. - A number of minor patches from Frank Denis, Gregor Herrmann and Barak A. Pearlmutter. - Testcase compilation fixes for OS X and FreeBSD - Do not let sockets be inherited by sub-processes, fixes #99. - Add unspecified RR type (called PRIVATE; id 65399, in private use range). For servers with RFC3597 support. Fixes #97. - Fix authentication bypass vulnerability; found by Oscar Reparaz.
15 lines
359 B
Text
15 lines
359 B
Text
$NetBSD: patch-aa,v 1.2 2014/06/26 18:54:09 wiz Exp $
|
|
|
|
Honour CPPFLAGS
|
|
|
|
--- src/Makefile.orig 2014-06-16 20:28:43.000000000 +0000
|
|
+++ src/Makefile
|
|
@@ -28,7 +28,7 @@ $(SERVER): $(COMMONOBJS) $(SERVEROBJS)
|
|
|
|
.c.o:
|
|
@echo CC $<
|
|
- @$(CC) $(CFLAGS) $< -o $@
|
|
+ @$(CC) $(CPPFLAGS) $(CFLAGS) $< -o $@
|
|
|
|
base64u.o client.o iodined.o: base64u.h
|
|
base64u.c: base64.c
|