bd1746ca4c
Changes: - Set default timing method to either gtod or abstime (#404) - Fix IPv6 parsing of CIDR's (#405) - Add support for preloading the memory cache (#410) - Generate more useful error when packets are too small (#411) - Update to libopts/Autogen 5.9.9 (#412) - Ship Win32Readme.txt file (#413) - Update copyright notice to 2010 (#416) - Dramatically enhance --portmap option (#417) - Update autotools (#423) - Add support for printing statistics periodically during the run (#424) - Warn user when pcap snaplen < 65535 (#425) - Add 802.1q processing support tcpprep (#428) - Link libnl when newer versions of libpcap require it (#397) - Ship m4 directory (#398) - Upgrade to latest autotools scripts (#400) - Fix error message when running autogen.sh (#401) - Added extensive IPv6 support to tcprewrite & tcpreplay-edit (#11) - Add IPv6 fragroute support (#388) - Add IPv6 decoding support to tcpprep (#11) - Fix compile time error in err.h (#390) - Add --endpoints support in tcpreplay-edit (#393)
34 lines
1.4 KiB
Text
34 lines
1.4 KiB
Text
$NetBSD: patch-aa,v 1.4 2013/10/31 02:25:17 minskim Exp $
|
|
|
|
--- configure.ac.orig 2010-04-05 00:58:05.000000000 +0000
|
|
+++ configure.ac
|
|
@@ -351,9 +351,9 @@ for testdir in $trypcapdir /usr/local /o
|
|
LPCAPINC="${testdir}/include/pcap.h"
|
|
LPCAPINCDIR="${testdir}/include"
|
|
if test $dynamic_link = yes; then
|
|
- if test -f "${testdir}/lib64/libpcap${shrext_cmds}" ; then
|
|
+ if test -e "${testdir}/lib64/libpcap${shrext_cmds}" ; then
|
|
LPCAPLIB="-L${testdir}/lib64 -lpcap"
|
|
- elif test -f "${testdir}/lib/libpcap${shrext_cmds}" ; then
|
|
+ elif test -e "${testdir}/lib/libpcap${shrext_cmds}" ; then
|
|
LPCAPLIB="-L${testdir}/lib -lpcap"
|
|
else
|
|
AC_ERROR([Unable to find libpcap in ${testdir}])
|
|
@@ -810,7 +810,7 @@ libdnet_version=
|
|
enable_fragroute=no
|
|
trydnetdir=/usr/local
|
|
|
|
-if test $have_cygwin == no ; then
|
|
+if test $have_cygwin = no ; then
|
|
AC_MSG_CHECKING(for libdnet)
|
|
AC_ARG_WITH(libdnet,
|
|
AC_HELP_STRING([--with-libdnet=DIR], [Use libdnet in DIR]),
|
|
@@ -1161,7 +1161,7 @@ case $host in
|
|
;;
|
|
esac])
|
|
|
|
-AM_CONDITIONAL([ENABLE_OSX_FRAMEWORKS], test "$osx_frameworks" == "yes")
|
|
+AM_CONDITIONAL([ENABLE_OSX_FRAMEWORKS], test "$osx_frameworks" = "yes")
|
|
|
|
AC_ARG_WITH(testnic2,
|
|
AC_HELP_STRING([--with-testnic2=NIC2], [Select an optional 2nd network card to use for testing]),
|