a14b596750
XULRunner is a runtime environment for applications using the XML User Interface Language, XUL. It is the successor of the "Gecko" runtime environment.
90 lines
2.7 KiB
Text
90 lines
2.7 KiB
Text
$NetBSD: patch-mg,v 1.1.1.1 2009/08/05 02:59:48 tnn Exp $
|
|
|
|
Add DragonFly support.
|
|
|
|
--- security/coreconf/DragonFly.mk.orig 2009-06-30 22:20:24.000000000 +0200
|
|
+++ security/coreconf/DragonFly.mk
|
|
@@ -0,0 +1,83 @@
|
|
+#
|
|
+# The contents of this file are subject to the Mozilla Public
|
|
+# License Version 1.1 (the "License"); you may not use this file
|
|
+# except in compliance with the License. You may obtain a copy of
|
|
+# the License at http://www.mozilla.org/MPL/
|
|
+#
|
|
+# Software distributed under the License is distributed on an "AS
|
|
+# IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
|
|
+# implied. See the License for the specific language governing
|
|
+# rights and limitations under the License.
|
|
+#
|
|
+# The Original Code is the Netscape security libraries.
|
|
+#
|
|
+# The Initial Developer of the Original Code is Netscape
|
|
+# Communications Corporation. Portions created by Netscape are
|
|
+# Copyright (C) 1994-2000 Netscape Communications Corporation. All
|
|
+# Rights Reserved.
|
|
+#
|
|
+# Contributor(s):
|
|
+#
|
|
+# Alternatively, the contents of this file may be used under the
|
|
+# terms of the GNU General Public License Version 2 or later (the
|
|
+# "GPL"), in which case the provisions of the GPL are applicable
|
|
+# instead of those above. If you wish to allow use of your
|
|
+# version of this file only under the terms of the GPL and not to
|
|
+# allow others to use your version of this file under the MPL,
|
|
+# indicate your decision by deleting the provisions above and
|
|
+# replace them with the notice and other provisions required by
|
|
+# the GPL. If you do not delete the provisions above, a recipient
|
|
+# may use your version of this file under either the MPL or the
|
|
+# GPL.
|
|
+#
|
|
+# Config stuff for DragonFly
|
|
+#
|
|
+
|
|
+include $(CORE_DEPTH)/coreconf/UNIX.mk
|
|
+
|
|
+DEFAULT_COMPILER = gcc
|
|
+CC = gcc
|
|
+CCC = g++
|
|
+RANLIB = ranlib
|
|
+
|
|
+ifeq ($(OS_TEST),alpha)
|
|
+CPU_ARCH = alpha
|
|
+else
|
|
+CPU_ARCH = x86
|
|
+endif
|
|
+
|
|
+OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
|
|
+
|
|
+DSO_CFLAGS = -fPIC
|
|
+DSO_LDOPTS = -shared -Wl,-soname -Wl,$(notdir $@)
|
|
+
|
|
+#
|
|
+# The default implementation strategy for FreeBSD is pthreads.
|
|
+#
|
|
+ifndef CLASSIC_NSPR
|
|
+USE_PTHREADS = 1
|
|
+DEFINES += -D_THREAD_SAFE -D_REENTRANT
|
|
+OS_LIBS += -pthread
|
|
+DSO_LDOPTS += -pthread
|
|
+endif
|
|
+
|
|
+ARCH = freebsd
|
|
+
|
|
+MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
|
|
+
|
|
+DLL_SUFFIX = so
|
|
+
|
|
+ifdef LIBRUNPATH
|
|
+DSO_LDOPTS += -Wl,-R$(LIBRUNPATH)
|
|
+endif
|
|
+
|
|
+MKSHLIB = $(CC) $(DSO_LDOPTS)
|
|
+ifdef MAPFILE
|
|
+# Add LD options to restrict exported symbols to those in the map file
|
|
+endif
|
|
+# Change PROCESS to put the mapfile in the correct format for this platform
|
|
+PROCESS_MAP_FILE = cp $(LIBRARY_NAME).def $@
|
|
+
|
|
+G++INCLUDES = -I/usr/include/g++
|
|
+
|
|
+INCLUDES += -I/usr/X11R6/include
|