pkgsrc/devel/scons/patches/patch-aa
adam 786065f672 Changes 2.3.2:
This release adds new features, and fixes and improves a number of issues. This will be the last release to support Python versions earlier than 2.7, as we begin to move toward supporting Python 3.
2014-07-19 12:30:49 +00:00

15 lines
561 B
Text

$NetBSD: patch-aa,v 1.6 2014/07/19 12:30:49 adam Exp $
Use PKGMANDIR.
--- setup.py.orig 2014-03-02 19:19:50.000000000 +0000
+++ setup.py
@@ -365,7 +362,7 @@ class install_data(_install_data):
if is_win32:
dir = 'Doc'
else:
- dir = os.path.join('man', 'man1')
+ dir = os.path.join(os.getenv("PKGMANDIR"), 'man1')
self.data_files = [(dir, man_pages)]
man_dir = os.path.join(self.install_dir, dir)
msg = "Installed SCons man pages into %s" % man_dir