pkgsrc/net/lftp/patches/patch-aa
pettai 0248607e57 Version 4.3.1 - 2011-06-28
* fixed a coredump in torrent on linux with a ppp interface.
* translation updated (ru).

Version 4.3.0 - 2011-06-17

* new command `attach' to control a backgrounded lftp.
* automatically fill torrent:ipv6 setting.
* slightly improved torrent status display.
* fixed reconnect interval (it was sometimes uninitialized).
* several fixes for the case of cmd:parallel>1
2011-07-27 04:57:47 +00:00

39 lines
1.5 KiB
Text

$NetBSD: patch-aa,v 1.17 2011/07/27 04:57:47 pettai Exp $
Do not install by default Perl scripts; they are installed via
${INSTALL_SCRIPT} if the user set the "perl" option.
Do not remove the *.la files.
$NetBSD: patch-aa,v 1.17 2011/07/27 04:57:47 pettai Exp $
--- src/Makefile.in.orig 2011-06-28 09:31:02.000000000 +0000
+++ src/Makefile.in
@@ -1265,7 +1265,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
pkgverlibdir = $(pkglibdir)/$(VERSION)
bin_SCRIPTS = lftpget
-pkgdata_SCRIPTS = import-ncftp import-netscape verify-file convert-mozilla-cookies
+pkgdata_SCRIPTS = import-ncftp import-netscape
noinst_SCRIPTS = ftpget
EXTRA_DIST = $(pkgdata_SCRIPTS) $(bin_SCRIPTS) $(noinst_SCRIPTS)
lftp_SOURCES = lftp.cc complete.h complete.cc lftp_rl.c lftp_rl.h attach.cc attach.h
@@ -1865,7 +1865,7 @@ all-am: Makefile $(LTLIBRARIES) $(PROGRA
install-binPROGRAMS: install-libLTLIBRARIES
installdirs:
- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgverlibdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgdatadir)"; do \
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgdatadir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-am
@@ -1995,6 +1995,9 @@ uninstall-am: uninstall-binPROGRAMS unin
# libtool does not strip modules, do it here.
install-data-hook:
+ :
+
+install-data-hook-disabled:
@WITH_MODULES_TRUE@ rm -f $(DESTDIR)$(pkgverlibdir)/*.la; \
@WITH_MODULES_TRUE@ case " $(LDFLAGS) " in *" -s "*) \
@WITH_MODULES_TRUE@ $(STRIP) $(DESTDIR)$(pkgverlibdir)/*.so;; \