2b77330a9a
First and foremost, I have added some patches that disable MPROTECT for some Racket executables and fix PR pkg/53467. As for changes since the latest version, 6.11, these include: * Changed the way some unsafe operations are exposed via `ffi/unsafe` libraries to help smooth a future transition to a new runtime system. * The `syntax-parse` form supports unwinding side-effects when it backtracks, both explicitly with `~undo` patterns and implicitly with the built-in managed state (using `syntax-parse-state-ref`, etc). * The `db` library supports SCRAM-SHA-256 authentication for backends running PostgreSQL 10 or later. Client support for SCRAM and other SASL mechanisms is provided by the new `sasl` library. * The `lazy-require-syntax` form supports lazy loading of macro transformers. Note that the macros must obey certain implementation constraints (see the `lazy-require-syntax` documentation). * Typed Racket no longer enforces types like `(U String (Boxof String))` with the `any/c` contract. This fixes a type soundness issue, but may affect performance. Please submit a bug report if you find a program that runs significantly slower on v6.12 than earlier versions. * Typed Racket's type instantiation (`inst`) uses `Any` for omitted type arguments, allowing APIs to add additional type variables to functions without breaking existing programs. * `for/fold` users can customize the final result of a loop's computation using the `#:result` keyword. * The `--deps` option to `raco test` tests the packages the argument packages depends on, in addition to testing the packages themselves. For example, `raco test -p --deps pkg1 pkg2` tests all files from `pkg1`, `pkg2`, and all of their dependencies.
17 lines
647 B
Text
17 lines
647 B
Text
$NetBSD: patch-src_gracket_Makefile.in,v 1.1 2018/07/24 12:22:07 jaapb Exp $
|
|
|
|
Disable MPROTECT for gracket
|
|
--- src/gracket/Makefile.in.orig 2017-10-12 18:23:27.000000000 +0000
|
|
+++ src/gracket/Makefile.in
|
|
@@ -108,7 +108,10 @@ both:
|
|
|
|
gracket@CGC@ : $(RACKETDEPS) grmain.@LTO@ $(GRACKETOBJECTS) $(MRSTATIC_STUB) $(GRACKETRESDEP)
|
|
$(GRACKETLINKER) $(GRACKETLDFLAGS) $(MRSTATIC) -o gracket@CGC@ $(GRACKETOBJECTS) $(GRACKETRES) $(GRACKETLDLIBS) $(MRSTATIC_STUB)
|
|
-
|
|
+ if [ -n "${PAXCTL}" ]; \
|
|
+ then ${PAXCTL} +m gracket@CGC@; \
|
|
+ fi
|
|
+
|
|
gres.o : $(srcdir)/../worksp/gracket/gracket.rc
|
|
@WINDRES@ -i $(srcdir)/../worksp/gracket/gracket.rc -o gres.o
|
|
|