pkgsrc/net/pppd/patches/patch-be
cube 3e86158156 Initial import of pppd, version 2.4.3, into the NetBSD Package Collection.
The PPP Daemon is the userland part of the Point-to-Point Protocol.  It works
in combination with a dedicated kernel network interface usually named ppp.
PPP is a very extensible protocol and pppd supports a large number of options,
including compression (through various algorithms), cryptography (Microsoft's
MPPE) and authentication (PAP, CHAP, Microsoft CHAP), provided the kernel has
the relevant back-ends in some cases.
2005-01-02 02:51:40 +00:00

26 lines
568 B
Text

$NetBSD: patch-be,v 1.1.1.1 2005/01/02 02:51:44 cube Exp $
--- pppdump/Makefile.netbsd.orig 2004-12-31 23:51:00.000000000 +0100
+++ pppdump/Makefile.netbsd
@@ -0,0 +1,21 @@
+DESTDIR = @DESTDIR@
+BINDIR = $(DESTDIR)/sbin
+MANDIR = $(DESTDIR)/man/man8
+
+CFLAGS= -O -I../include/net
+OBJS = pppdump.o bsd-comp.o deflate.o
+
+INSTALL= install
+
+all: pppdump
+
+pppdump: $(OBJS)
+ $(CC) -o pppdump $(OBJS) -lz
+
+clean:
+ rm -f pppdump $(OBJS) *~
+
+install:
+ mkdir -p $(BINDIR) $(MANDIR)
+ $(INSTALL) -s -c pppdump $(BINDIR)
+ $(INSTALL) -c -m 444 pppdump.8 $(MANDIR)