directories to process. The removal of pre-configure fixes the config.* handling at the same time. Also specify the config.status overrides. Patch configure to not try to detect -lrfftw, just link the static version explicitly. Do the same for -lfftw. This ensures that we actually do get the static versions without having to worry about libtool being too clever. Retire manual config.sub hacks, this should be handled by config.guess already. <jlam> just go ahead and commit that benchfft patch and let's <jlam> never speak of it again :)
31 lines
883 B
Text
31 lines
883 B
Text
$NetBSD: patch-ac,v 1.2 2005/11/05 21:04:36 joerg Exp $
|
|
|
|
need to be able to link with -lf2c when using f2c or -lg2c when using
|
|
g77.
|
|
|
|
--- configure.in.orig Tue Oct 20 12:42:05 1998
|
|
+++ configure.in Fri May 12 17:10:03 2000
|
|
@@ -58,6 +58,7 @@ if test $F77 = echo; then
|
|
else
|
|
USE_F77=" "
|
|
AC_DEFINE(HAVE_F77)
|
|
+ AC_F77_LIBRARY_LDFLAGS
|
|
fi
|
|
|
|
if test $F90 = echo; then
|
|
@@ -158,13 +159,8 @@ AC_CHECK_FUNCS(dcft3)
|
|
|
|
dnl Check for librfftw.a (in rfftw 2.0+)
|
|
AC_MSG_CHECKING(for location of rfftw)
|
|
-if test -r $FFTWDIR/rfftw/.libs/librfftw.a; then
|
|
- RFFTWLIB="-lrfftw"
|
|
- AC_MSG_RESULT(found librfftw.a)
|
|
-else
|
|
- RFFTWLIB="$FFTWDIR/rfftw/rfftw.o $FFTWDIR/rfftw/rfftwnd.o"
|
|
- AC_MSG_RESULT(using rfftw object code)
|
|
-fi
|
|
+RFFTWLIB="$FFTWDIR/rfftw/.libs/librfftw.a"
|
|
+AC_MSG_RESULT(found librfftw.a)
|
|
AC_SUBST(RFFTWLIB)
|
|
|
|
dnl Check for Numerical Recipes code:
|