pkgsrc/mail/exim3/patches/patch-ab
abs 4e437bb2bc Update exim3 to exim-3.36nb2
- Fix buffer overflows listed at http://www.guninski.com/exim1.html

Update exim to exim-4.33nb1 (from 4.22nb5)
  - Fix buffer overflow listed at http://www.guninski.com/exim1.html
  - Leave nb1 to indicate we have a local change from stock 4.33
  - 1086 lines of changes - http://www.exim.org/ftp/ChangeLogs/ChangeLog-4.33
  - Remove dependancy on exim-user - now looks up EXIM_{USER,GROUP} at runtime

Update exim-exiscan to 4.33_20nb1 (from 4.22-12)
  - Fix buffer overflow listed at http://www.guninski.com/exim1.html
  - Leave nb1 to indicate we have a local change from stock 4.33_20
  - Same exim changes - http://www.exim.org/ftp/ChangeLogs/ChangeLog-4.33
  - Changes (http://duncanthrax.net/exiscan-acl/CHANGELOG) include
    - added option to use multiple spamd servers
    - many mime changes
    - Added Brightmail Antispam support
    - clamd fixes

Update exim-html to 4.30 (from 4.20)
  - Update to latest docs

Delete exim-user
  - No longer required - exim now looks up EXIM_{USER,GROUP} at runtime
2004-05-07 17:47:32 +00:00

44 lines
897 B
Text

$NetBSD: patch-ab,v 1.2 2004/05/07 17:47:32 abs Exp $
--- OS/Makefile-NetBSD.orig Thu Apr 4 13:56:13 2002
+++ OS/Makefile-NetBSD
@@ -3,15 +3,31 @@
# Include Makfile.NetBSD-a.out
-.if exists(OS/Makefile-NetBSD-a.out)
-.include "OS/Makefile-NetBSD-a.out"
-.elif exists(../OS/Makefile-NetBSD-a.out)
-.include "../OS/Makefile-NetBSD-a.out"
-.else
-.include "Makefile.NetBSD-a.out, submit a bug report."
-.endif
+# Exim: OS-specific make file for NetBSD (a.out binary format)
+
+CHOWN_COMMAND=/usr/sbin/chown
+CFLAGS=-O
+
+HAVE_SA_LEN=YES
+LIBS=-lcrypt
+
+X11=/usr/X11R6
+XINCLUDE=-I$(X11)/include
+XLFLAGS=-L$(X11)/lib
+X11_LD_LIB=$(X11)/lib
+
+EXIWHAT_PS_ARG=-ax
+EXIWHAT_EGREP_ARG='/exim( |$$)'
+EXIWHAT_KILL_ARG=-USR1
+
+# NetBSD always ships with Berkeley DB
+
+USE_DB=yes
+
+# End
+
# NetBSD ELF linker needs a -R flag.
-XLFLAGS+=-Wl,-R$(X11)/lib/
+#XLFLAGS+=-Wl,-R$(X11)/lib/
# End