e1a319634a
- security fix for users of tmail or dmail. - bug fixes and reliability improvements. - A new function, utf8_csvalidmap(), has been added for the benefit of Alpine to use in examining UTF-8 text and determining efficiently whether it can be downgraded to a legacy charset. If you develop an MUA, this may be useful for you too, although you'll have to read the source code to see how to use it. The purpose of the "not-CJK" bit is to prevent messages being downgraded to a CJK charset if all they have in that charset are some special punctuation. This update address the security vulnerability reported in SA32483.
22 lines
622 B
Text
22 lines
622 B
Text
$NetBSD: patch-ae,v 1.18 2008/11/06 15:27:00 tron Exp $
|
|
|
|
--- src/tmail/Makefile.orig 2008-06-04 19:18:34.000000000 +0100
|
|
+++ src/tmail/Makefile 2008-11-06 13:32:39.000000000 +0000
|
|
@@ -26,7 +26,7 @@
|
|
|
|
|
|
C = ../c-client
|
|
-CCLIENTLIB = $C/c-client.a
|
|
+CCLIENTLIB = $C/libc-client.la
|
|
SHELL = /bin/sh
|
|
|
|
# Get local definitions from c-client directory
|
|
@@ -36,7 +36,7 @@
|
|
LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
|
|
|
|
tmail: $(CCLIENTLIB) tmail.o tquota.o
|
|
- $(CC) $(CFLAGS) -o tmail tmail.o tquota.o $(LDFLAGS)
|
|
+ $(LTLINK) $(CC) $(CFLAGS) -o tmail tmail.o tquota.o $(LDFLAGS)
|
|
|
|
tmail.o: $C/mail.h $C/misc.h $C/osdep.h tquota.h
|
|
|